summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-14 16:09:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-15 13:02:53 -0400
commitca3fea7636d07d3063b66158a8ca207cff53b0bb (patch)
treee0c1fd414ba3f203a74502144320aac1dd8c5334 /gnu/packages/python-check.scm
parent0930ca2c63fb57d9d7dba5bfb0f092ba3f09d961 (diff)
downloadguix-patches-ca3fea7636d07d3063b66158a8ca207cff53b0bb.tar
guix-patches-ca3fea7636d07d3063b66158a8ca207cff53b0bb.tar.gz
gnu: Add python-pytest-mockito.
* gnu/packages/python-check.scm (python-pytest-mockito): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 0421210c27..fc3c8f51af 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -611,6 +611,46 @@ enables repeating a single test, or multiple tests, a specific number of
times.")
(license license:mpl2.0)))
+(define-public python-pytest-mockito
+ (package
+ (name "python-pytest-mockito")
+ (version "0.0.4")
+ (source
+ (origin
+ (method git-fetch) ;no tests in pypi archive
+ (uri (git-reference
+ (url "https://github.com/kaste/pytest-mockito")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hnpazaw3mglx1c405z2hkavgan99rqb3wgrcqk8x5kmhpay53xx"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-vv")))))))
+ (propagated-inputs
+ `(("python-mockito" ,python-mockito)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/kaste/pytest-mockito")
+ (synopsis "Mockito base fixtures for Pytest")
+ (description "The @code{pytest-mockito} plugin provides base Mockito
+fixtures for Pytest. It covers the main entry points of the Mockito mocking
+framework and makes it easy to undo any monkey patching. The fixtures are:
+@itemize
+@item when
+@item when2
+@item expect
+@item patch
+@item unstub
+@item spy2
+@end itemize")
+ (license license:expat)))
+
(define-public python-pytest-mpl
(package
(name "python-pytest-mpl")