summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-09-30 21:00:28 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-10-22 16:58:29 +0200
commitc1ff9072de7738feb5af5274d7c478f1efef0f09 (patch)
treeaf785b431007734d1af778cdd66811a369c1bdb8 /gnu/packages/python-check.scm
parent0201e34cef3cc908e40f54818c8228fa8e786676 (diff)
downloadguix-patches-c1ff9072de7738feb5af5274d7c478f1efef0f09.tar
guix-patches-c1ff9072de7738feb5af5274d7c478f1efef0f09.tar.gz
gnu: Add python-pytest-isort.
* gnu/packages/python-check.scm (python-pytest-isort): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 15cf9138d4..caa398752e 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -153,6 +154,36 @@ of the project to ensure it renders properly.")
compliance.")
(license license:bsd-3)))
+(define-public python-pytest-isort
+ (package
+ (name "python-pytest-isort")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-isort" version))
+ (sha256
+ (base32 "06myn5hhxs5yp8dqr1yjsgcnnxnsrvsqannm00bvaw0qml6ydzjb"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) ":"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest"))))))
+ (propagated-inputs
+ `(("python-isort" ,python-isort)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/moccu/pytest-isort/")
+ (synopsis "Pytest plugin to check import ordering using isort")
+ (description
+ "This package provides a pytest plugin to check import ordering using
+isort.")
+ (license license:bsd-3)))
+
(define-public python-pytest-shutil
(package
(name "python-pytest-shutil")