summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-29 18:30:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-30 16:46:17 +0100
commitbfaf7b559e80d246ddfcbabbe8f6a100e1764aaf (patch)
tree2034a553abdb3b53d0a6c8d6da075613c801c17b /gnu/packages/python-check.scm
parent173a2998d9facce29386788d25bcc08781386f60 (diff)
downloadguix-patches-bfaf7b559e80d246ddfcbabbe8f6a100e1764aaf.tar
guix-patches-bfaf7b559e80d246ddfcbabbe8f6a100e1764aaf.tar.gz
gnu: Add python-xunitparser.
* gnu/packages/python-check.scm (python-xunitparser): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 5b230934a5..ef8629a91b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -1799,3 +1799,30 @@ asynchronous HTTP requests it is a bit harder (at least at the beginning).
The purpose of this package is to provide an easy way to test asynchronous
HTTP requests.")
(license license:expat)))
+
+(define-public python-xunitparser
+ (package
+ (name "python-xunitparser")
+ (version "1.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "xunitparser" version))
+ (sha256
+ (base32 "05amn9yik0mxg89iiprkb6lrmc7rlccgvwajrpyfi6zbp8mjdsgn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/laurentb/xunitparser/pull/11
+ (add-after 'unpack 'fix-test-suite
+ (lambda _
+ (substitute* "xunitparser.py"
+ (("(^ +)self.stderr = None" m indent)
+ (string-append m "\n" indent "self._cleanup = False\n"))))))))
+ (home-page "http://git.p.engu.in/laurentb/xunitparser/")
+ (synopsis "Read JUnit/XUnit XML files and map them to Python objects")
+ (description "xunitparser reads a JUnit/XUnit XML file and maps it to
+Python objects. It tries to use the objects available in the standard
+@code{unittest} module.")
+ (license license:expat)))