summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-04-12 09:50:54 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-04-12 09:50:54 +0200
commitbceca1ff58cbf8d26b701b70c3e129f727d81b8e (patch)
tree1885ff2255b58403e702d01d4e0fa59368d5e22d /gnu/packages/python-check.scm
parente18e2e458fe584ee9eaeca40adbdcef895d32abf (diff)
downloadguix-patches-bceca1ff58cbf8d26b701b70c3e129f727d81b8e.tar
guix-patches-bceca1ff58cbf8d26b701b70c3e129f727d81b8e.tar.gz
gnu: Add python-allpairspy.
* gnu/packages/python-check.scm (python-allpairspy): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 961d245630..bde836a931 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1310,3 +1311,26 @@ help in debugging failures and optimizing the scheduler to improve speed.")
(description "A pytest plugin for Sanic. It helps you to test your
code asynchronously.")
(license license:expat)))
+
+(define-public python-allpairspy
+ (package
+ (name "python-allpairspy")
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "allpairspy" version))
+ (sha256
+ (base32 "1c987h13dly9919d15w3h747rgn50ilnv7dginhlprxbj564hn4k"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/thombashi/allpairspy")
+ (synopsis "Pairwise test combinations generator")
+ (description
+ "This is a Python library for test combinations generator. The generator
+allows one to create a set of tests using @emph{pairwise combinations} method,
+reducing a number of combinations of variables into a lesser set that covers
+most situations.")
+ (license license:expat)))