summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-19 00:29:08 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 00:00:02 +0100
commit9665660e4bc5be20e59427379c06f4d514fb8c53 (patch)
treea99959361a02f8893a6b1c328cede4c9fbdd0328 /gnu/packages/python-check.scm
parentc89a690d0bb96104f5edf84d7fbd9140c683097b (diff)
downloadguix-patches-9665660e4bc5be20e59427379c06f4d514fb8c53.tar
guix-patches-9665660e4bc5be20e59427379c06f4d514fb8c53.tar.gz
gnu: Add python-pytest-subtests.
* gnu/packages/python-check.scm (python-pytest-subtests): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 50e63cb734..f1ab28273e 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -716,6 +716,33 @@ in Pytest.")
settings.")
(license license:expat)))
+(define-public python-pytest-subtests
+ (package
+ (name "python-pytest-subtests")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-subtests" version))
+ (sha256
+ (base32 "087i03nmkmfnrpc7mmizvr40ijnjw4lfxc22rnk8jk6s1szy9lav"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ (list python-pytest python-setuptools-scm))
+ (home-page "https://github.com/pytest-dev/pytest-subtests")
+ (synopsis "Unittest subTest() support and subtests fixture")
+ (description "This Pytest plugin provides unittest @code{subTest()}
+support and @code{subtests} fixture.")
+ (license license:expat)))
+
(define-public python-pytest-vcr
;; This commit fixes integration with pytest-5
(let ((commit "4d6c7b3e379a6a7cba0b8f9d20b704dc976e9f05")