summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-04 14:47:22 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-10 12:01:49 +0100
commit955fcf0a19d2e328edf429eee251c46dda85d776 (patch)
tree6f8f2aeec5f19ecea4ac0e81a7aac570e7f03f23 /gnu/packages/python-check.scm
parent548d0ddd7fbf91c860b5061d4f6ac58ed249ec5d (diff)
downloadguix-patches-955fcf0a19d2e328edf429eee251c46dda85d776.tar
guix-patches-955fcf0a19d2e328edf429eee251c46dda85d776.tar.gz
gnu: python-pytest-sanic: Update to 1.7.0.
* gnu/packages/python-check.scm (python-pytest-sanic) [version]: Update to 1.7.0. [propagated-inputs]: Replace python-aiohttp with python-httpx and add python-websockets.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 15efdd3297..3eb561c89a 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1237,22 +1237,23 @@ help in debugging failures and optimizing the scheduler to improve speed.")
(define-public python-pytest-sanic
(package
(name "python-pytest-sanic")
- (version "1.6.2")
+ (version "1.7.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "pytest-sanic" version))
(sha256
(base32
- "02ajd8z77ahi69kzkz200qgxrb4s2j4qb6k8j9ds1kz6qa6fsa34"))))
+ "0hm7im77dgqfk8k34qbbfhimg8hifl4zwpa2s3mgbknrjvyw5qpx"))))
(build-system python-build-system)
(arguments
;; Tests depend on python-sanic.
`(#:tests? #f))
(propagated-inputs
- `(("python-aiohttp" ,python-aiohttp)
+ `(("python-httpx" ,python-httpx)
("python-async-generator"
,python-async-generator)
- ("python-pytest" ,python-pytest)))
+ ("python-pytest" ,python-pytest)
+ ("python-websockets" ,python-websockets)))
(home-page
"https://github.com/yunstanford/pytest-sanic")
(synopsis "Pytest plugin for Sanic")