summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-23 15:23:28 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:56 +0200
commit8ea5d35e5c96a8eba931b22d6318b542b74172ff (patch)
tree6f5909c7789e0a411db4043348344ac2dd64b154 /gnu/packages/python-check.scm
parent04a3cb9984a81bbac2dc1f2ac8d00fc12cd4b96d (diff)
downloadguix-patches-8ea5d35e5c96a8eba931b22d6318b542b74172ff.tar
guix-patches-8ea5d35e5c96a8eba931b22d6318b542b74172ff.tar.gz
gnu: Add python-pytest-mpl.
* gnu/packages/python-check.scm (python-pytest-mpl): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 506b95556c..687fe2c778 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -282,6 +282,35 @@ developers to control unit tests that require access to data from the
internet.")
(license license:bsd-3)))
+(define-public python-pytest-mpl
+ (package
+ (name "python-pytest-mpl")
+ (version "0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-mpl" version))
+ (sha256
+ (base32 "1km202c1s5kcn52fx0266p06qb34va3warcby594dh6vixxa9i96"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-matplotlib" ,python-matplotlib)
+ ("python-pillow" ,python-pillow)))
+ (home-page "https://github.com/matplotlib/pytest-mpl")
+ (synopsis "Pytest plugin to help with testing figures output from Matplotlib")
+ (description
+ "This is a plugin to facilitate image comparison for Matplotlib figures
+in Pytest.")
+ (license license:bsd-3)))
+
(define-public python-pytest-vcr
;; This commit fixes integration with pytest-5
(let ((commit "4d6c7b3e379a6a7cba0b8f9d20b704dc976e9f05")