summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-06-02 11:44:56 +0200
committerMarius Bakke <marius@gnu.org>2020-06-22 23:52:54 +0200
commit85acb5f53d8bebb5e9e61727e61f6a4e6d3be7be (patch)
tree6a2bf531aee8933a759913a0fad019a190a1341e /gnu/packages/python-check.scm
parent857c63fe03f1fd91722814b720d3762c91396441 (diff)
downloadguix-patches-85acb5f53d8bebb5e9e61727e61f6a4e6d3be7be.tar
guix-patches-85acb5f53d8bebb5e9e61727e61f6a4e6d3be7be.tar.gz
gnu: Add python-pytest-flask.
* gnu/packages/python-check.scm (python-pytest-flask): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 0ab6aa8f47..7d8647cb44 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -384,6 +384,29 @@ for the @code{pytest} framework.")
rounds that are calibrated to the chosen timer.")
(license license:bsd-2)))
+(define-public python-pytest-flask
+ (package
+ (name "python-pytest-flask")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-flask" version))
+ (sha256
+ (base32
+ "1hln7mwgdzfi5ma0kqfsi768l7p24jhkw8l0imhifwy08nh7hmjd"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-flask" ,python-flask)
+ ("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-werkzeug" ,python-werkzeug)))
+ (home-page "https://github.com/pytest-dev/pytest-flask")
+ (synopsis "Pytest fixtures to test Flask applications")
+ (description
+ "This pytest plugin provides fixtures to simplify Flask app testing.")
+ (license license:expat)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")