summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-12 23:53:54 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:44 -0400
commit8194b36ddf34fdae110c7feb5b3c7c3a97c6e42a (patch)
tree3b22310ef61dd900acede56ac91287737965de72 /gnu/packages/python-check.scm
parent53e179c752a7e0a289d845f1dc92883dd335e1f2 (diff)
downloadguix-patches-8194b36ddf34fdae110c7feb5b3c7c3a97c6e42a.tar
guix-patches-8194b36ddf34fdae110c7feb5b3c7c3a97c6e42a.tar.gz
gnu: Add python-pytest-tornado.
* gnu/packages/python-check.scm (python-pytest-tornado): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 5469200afc..465c425a79 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1420,6 +1420,36 @@ also ensuring that the notebooks are running without errors.")
"This package provides a pytest plugin for testing console scripts.")
(license license:expat)))
+(define-public python-pytest-tornado
+ (package
+ (name "python-pytest-tornado")
+ (version "0.8.1")
+ (source (origin
+ (method git-fetch) ;no tests in pypi archive
+ (uri (git-reference
+ (url "https://github.com/eugeniy/pytest-tornado")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05hgq1m9g35kpc01im7ci1wd85xi1rdxnyms9izjg65c9976zn6x"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (propagated-inputs (list python-pytest python-setuptools python-tornado))
+ (home-page "https://github.com/eugeniy/pytest-tornado")
+ (synopsis "Pytest plugin to ease testing tornado applications")
+ (description
+ "This package provides a py.test plugin providing fixtures and markers to
+simplify testing of asynchronous tornado applications.")
+ (license license:asl2.0)))
+
(define-public python-pytest-tornasync
(package
(name "python-pytest-tornasync")