summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-11-13 09:54:01 +0100
committerLeo Famulari <leo@famulari.name>2020-12-15 01:55:38 -0500
commit7ae45716848b6f660eff86911f599a1626b51b55 (patch)
treece138ed4310ee2fc2882bf8d6d131beae0e6bef9 /gnu/packages/python-check.scm
parent6655b975a0798a0473d23d134188fc39d8147b2c (diff)
downloadguix-patches-7ae45716848b6f660eff86911f599a1626b51b55.tar
guix-patches-7ae45716848b6f660eff86911f599a1626b51b55.tar.gz
gnu: Add python-pytest-sanic.
* gnu/packages/python-check.scm (python-pytest-sanic): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 72026473ca..fb111d6e57 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1153,3 +1153,30 @@ execute @code{unittest} test suites using multiple processes to split up
execution of a test suite. It will also store a history of all test runs to
help in debugging failures and optimizing the scheduler to improve speed.")
(license license:asl2.0)))
+
+;; This is only used by python-sanic
+(define-public python-pytest-sanic
+ (package
+ (name "python-pytest-sanic")
+ (version "1.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-sanic" version))
+ (sha256
+ (base32
+ "02ajd8z77ahi69kzkz200qgxrb4s2j4qb6k8j9ds1kz6qa6fsa34"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Tests depend on python-sanic.
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-aiohttp" ,python-aiohttp)
+ ("python-async-generator"
+ ,python-async-generator)
+ ("python-pytest" ,python-pytest)))
+ (home-page
+ "https://github.com/yunstanford/pytest-sanic")
+ (synopsis "Pytest plugin for Sanic")
+ (description "A pytest plugin for Sanic. It helps you to test your
+code asynchronously.")
+ (license license:expat)))