summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-15 13:30:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-15 13:30:32 +0300
commit68845693a472bed4bc3142d8badbe577158613bd (patch)
tree37975b32830d8fb8203b362e7a3dd5af67e0ac0e /gnu/packages/python-check.scm
parentdda6b8b99f69ab253f11da166ffc4d81869d6278 (diff)
downloadguix-patches-68845693a472bed4bc3142d8badbe577158613bd.tar
guix-patches-68845693a472bed4bc3142d8badbe577158613bd.tar.gz
gnu: python-pytest-trio: Update to 0.7.0.
* gnu/packages/python-check.scm (python-pytest-trio): Update to 0.7.0. [arguments]: Add some tests to skip. [propagated-inputs]: Add python-async-generator, python-outcome, python-pytest.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 413cb6b6e5..fd9e0bece9 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -768,13 +768,13 @@ simpler.")
(define-public python-pytest-trio
(package
(name "python-pytest-trio")
- (version "0.6.0")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-trio" version))
(sha256
- (base32 "1zm8didm9h5jkqhghl9bvqs7kr7sjci282c7grhk6yhpzn8a9w4v"))))
+ (base32 "0c8cqf9by2884riksrqymqfp2g1d2d798a2zalcw9hmf34c786y0"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -783,13 +783,19 @@ simpler.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "pytest" "-W" "error" "-ra" "-v" "--pyargs"
- "pytest_trio" "--verbose" "--cov"))))))
+ "pytest_trio" "--verbose" "--cov" "-k"
+ (string-append
+ ;; Needs network
+ "not test_async_yield_fixture_with_nursery"
+ " and not test_try"
+ ;; No keyboard interrupt in our build environment.
+ " and not test_actual_test")))))))
(native-inputs
`(("python-hypothesis" ,python-hypothesis)
("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)))
(propagated-inputs
- `(("python-trio" ,python-trio)))
+ (list python-async-generator python-outcome python-pytest python-trio))
(home-page "https://github.com/python-trio/pytest-trio")
(synopsis "Pytest plugin for trio")
(description