summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-27 23:30:31 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 18:07:30 +0100
commit3d2ea6a50b806ba27db8f1c3c2ad34bb5553b511 (patch)
treec496a4981922757fc6e0fc7a91fd06f01181e48d /gnu/packages/python-check.scm
parenta3d0a702ad4cae5dbd089625c6106a74736be500 (diff)
downloadguix-patches-3d2ea6a50b806ba27db8f1c3c2ad34bb5553b511.tar
guix-patches-3d2ea6a50b806ba27db8f1c3c2ad34bb5553b511.tar.gz
gnu: Add python-pytest-doctest-custom.
* gnu/packages/python-check.scm (python-pytest-doctest-custom): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b4e2765d72..6d8e3560d9 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -776,6 +776,35 @@ support and @code{subtests} fixture.")
"Plugin for managing VCR.py cassettes.")
(license license:expat))))
+(define-public python-pytest-doctest-custom
+ (package
+ (name "python-pytest-doctest-custom")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-doctest-custom" version))
+ (sha256
+ (base32 "0kxkdd6q9c3h31kc88lbyfll4c45b0zjd24cbr4c083fcvcy7lip"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "test_pytest_doctest_custom.py")))))))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://github.com/danilobellini/pytest-doctest-custom")
+ (synopsis
+ "Pytest plugin to customize string representations of doctest results")
+ (description "This package provides a Pytest plugin for customizing string
+representations of doctest results. It can change the display hook used by
+doctest to render the object representations.")
+ (license license:expat)))
+
(define-public python-pytest-checkdocs
(package
(name "python-pytest-checkdocs")