summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-17 23:24:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:43:14 +0100
commit3a317f7476f8c6012e166ff9f340f861938721c9 (patch)
tree946e398c37912cfc03be7306951ae87bfeb130fa /gnu/packages/python-check.scm
parente55547bf70384691712047912c793c517debd2ec (diff)
parent62e707d67caf1dab2af411a69ff8cec4b2dc686e (diff)
downloadguix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar
guix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm35
1 files changed, 21 insertions, 14 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index cb812762c9..bec6417151 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -341,21 +341,28 @@ Astropy project, but is optimized for use with astropy-related projects.")
(base32 "18j6z6y2fvykmcs5z0mldhhaxxn6wzpnhlm2ps7m8r5z5kmh1631"))))
(build-system python-build-system)
(arguments
- ;; No tests provided
- '(#:tests? #f))
+ `(#:tests? #f ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ ;; There is a bug somewhere that makes pytest-filter-subpackage appear
+ ;; as version 0.0.0 to setup.py. Remove it from the requirements.
+ (add-after 'unpack 'remove-requirement
+ (lambda _
+ (substitute* "setup.cfg"
+ ((".*pytest-filter-subpackage.*") "")))))))
(native-inputs
- `(("attrs" ,python-attrs)
- ("hypothesis" ,python-hypothesis)
- ("pytest" ,python-pytest)
- ("pytest-arraydiff" ,python-pytest-arraydiff)
- ("pytest-astropy-header" ,python-pytest-astropy-header)
- ("pytest-cov" ,python-pytest-cov)
- ("pytest-doctestplus" ,python-pytest-doctestplus)
- ("pytest-filter-subpackage" ,python-pytest-filter-subpackage)
- ("pytest-mock" ,python-pytest-mock)
- ("pytest-openfiles" ,python-pytest-openfiles)
- ("pytest-remotedata" ,python-pytest-remotedata)
- ("setuptools-scm" ,python-setuptools-scm)))
+ `(("python-attrs" ,python-attrs)
+ ("python-pytest-mock" ,python-pytest-mock)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-hypothesis" ,python-hypothesis)
+ ("python-pytest-arraydiff" ,python-pytest-arraydiff)
+ ("python-pytest-astropy-header" ,python-pytest-astropy-header)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-doctestplus" ,python-pytest-doctestplus)
+ ("python-pytest-filter-subpackage" ,python-pytest-filter-subpackage)
+ ("python-pytest-openfiles" ,python-pytest-openfiles)
+ ("python-pytest-remotedata" ,python-pytest-remotedata)))
(home-page "https://github.com/astropy/pytest-astropy")
(synopsis
"Metapackage for all the testing machinery used by the Astropy Project")