summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:28:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:50:44 +0200
commit2aab587f842908a886e3bd08b028885dddd650e0 (patch)
tree87c0723a9ae2c69ab6920d90b6e87ad8510492fe /gnu/packages/python-check.scm
parent5664bcdcb0e4c10dfe48dd5e4730fc3c746a21e2 (diff)
parent65c46e79e0495fe4d32f6f2725d7233fff10fd70 (diff)
downloadguix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar
guix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm36
1 files changed, 32 insertions, 4 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f98a6bb37b..f7342c6436 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -29,7 +29,9 @@
(define-module (gnu packages python-check)
#:use-module (gnu packages)
#:use-module (gnu packages check)
+ #:use-module (gnu packages django)
#:use-module (gnu packages openstack)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages web)
@@ -41,6 +43,31 @@
#:use-module (guix download)
#:use-module (guix build-system python))
+(define-public python-testfixtures
+ (package
+ (name "python-testfixtures")
+ (version "6.17.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "testfixtures" version))
+ (sha256
+ (base32 "1nlv2hz20czjp4a811ichl5kwg99rh84l0mw9wq4rk3idzfs1hsy"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; PyTest-Django fails to build in master
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ;;("python-pytest-django" ,python-pytest-django)
+ ("python-twine" ,python-twine)
+ ("python-wheel" ,python-wheel)))
+ (synopsis "Tests components for Python")
+ (description "Testfixtures is a collection of helpers and mock objects that
+are useful when writing automated tests in Python.")
+ (home-page "https://testfixtures.readthedocs.io/en/latest/")
+ (license license:expat)))
+
(define-public python-coveralls
(package
(name "python-coveralls")
@@ -1289,22 +1316,23 @@ help in debugging failures and optimizing the scheduler to improve speed.")
(define-public python-pytest-sanic
(package
(name "python-pytest-sanic")
- (version "1.6.2")
+ (version "1.7.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "pytest-sanic" version))
(sha256
(base32
- "02ajd8z77ahi69kzkz200qgxrb4s2j4qb6k8j9ds1kz6qa6fsa34"))))
+ "0hm7im77dgqfk8k34qbbfhimg8hifl4zwpa2s3mgbknrjvyw5qpx"))))
(build-system python-build-system)
(arguments
;; Tests depend on python-sanic.
`(#:tests? #f))
(propagated-inputs
- `(("python-aiohttp" ,python-aiohttp)
+ `(("python-httpx" ,python-httpx)
("python-async-generator"
,python-async-generator)
- ("python-pytest" ,python-pytest)))
+ ("python-pytest" ,python-pytest)
+ ("python-websockets" ,python-websockets)))
(home-page
"https://github.com/yunstanford/pytest-sanic")
(synopsis "Pytest plugin for Sanic")