summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-30 02:51:31 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 10:04:31 +0200
commit27b0e71ecdfb747fe42b9d0708e5c8f2f3ed4c17 (patch)
treee179d89a9c5707f5d73a80466144b05d24fd8f5d /gnu/packages/python-check.scm
parent56dcaff82733149697047f05836f0498b1fde17a (diff)
downloadguix-patches-27b0e71ecdfb747fe42b9d0708e5c8f2f3ed4c17.tar
guix-patches-27b0e71ecdfb747fe42b9d0708e5c8f2f3ed4c17.tar.gz
gnu: python-pytest-astropy: Adjust inputs.
* gnu/packages/python-check.scm (python-pytest-astropy)[arguments]: Add new phase to skip a version check bug. [native-inputs]: Remove python-pytest. Move python-hypothesis, python-pytest-arraydiff, python-pytest-astropy-header, python-pytest-cov, python-pytest-filter-subpackage, python-pytest-openfiles, python-pytest-remotedata to ... [propagated-inputs]: ... here. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm35
1 files changed, 21 insertions, 14 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index a13bd0baa4..5b230934a5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -341,21 +341,28 @@ Astropy project, but is optimized for use with astropy-related projects.")
(base32 "18j6z6y2fvykmcs5z0mldhhaxxn6wzpnhlm2ps7m8r5z5kmh1631"))))
(build-system python-build-system)
(arguments
- ;; No tests provided
- '(#:tests? #f))
+ `(#:tests? #f ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ ;; There is a bug somewhere that makes pytest-filter-subpackage appear
+ ;; as version 0.0.0 to setup.py. Remove it from the requirements.
+ (add-after 'unpack 'remove-requirement
+ (lambda _
+ (substitute* "setup.cfg"
+ ((".*pytest-filter-subpackage.*") "")))))))
(native-inputs
- `(("attrs" ,python-attrs)
- ("hypothesis" ,python-hypothesis)
- ("pytest" ,python-pytest)
- ("pytest-arraydiff" ,python-pytest-arraydiff)
- ("pytest-astropy-header" ,python-pytest-astropy-header)
- ("pytest-cov" ,python-pytest-cov)
- ("pytest-doctestplus" ,python-pytest-doctestplus)
- ("pytest-filter-subpackage" ,python-pytest-filter-subpackage)
- ("pytest-mock" ,python-pytest-mock)
- ("pytest-openfiles" ,python-pytest-openfiles)
- ("pytest-remotedata" ,python-pytest-remotedata)
- ("setuptools-scm" ,python-setuptools-scm)))
+ `(("python-attrs" ,python-attrs)
+ ("python-pytest-mock" ,python-pytest-mock)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-hypothesis" ,python-hypothesis)
+ ("python-pytest-arraydiff" ,python-pytest-arraydiff)
+ ("python-pytest-astropy-header" ,python-pytest-astropy-header)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-doctestplus" ,python-pytest-doctestplus)
+ ("python-pytest-filter-subpackage" ,python-pytest-filter-subpackage)
+ ("python-pytest-openfiles" ,python-pytest-openfiles)
+ ("python-pytest-remotedata" ,python-pytest-remotedata)))
(home-page "https://github.com/astropy/pytest-astropy")
(synopsis
"Metapackage for all the testing machinery used by the Astropy Project")