summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-22 09:29:20 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:23:01 +0100
commit22acec058803d98a0ed3bacc0734339cadae0d74 (patch)
tree3d609372c0866852c4b6dbbd242316ff136aaf81 /gnu/packages/python-check.scm
parent36481d00de7137d055368f92c409c917a6fadfe8 (diff)
downloadguix-patches-22acec058803d98a0ed3bacc0734339cadae0d74.tar
guix-patches-22acec058803d98a0ed3bacc0734339cadae0d74.tar.gz
gnu: Add python-cucumber-tag-expressions.
* gnu/packages/python-check.scm (python-cucumber-tag-expressions): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2ab6686bbc..f971dae5b4 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -145,6 +145,35 @@ are useful when writing automated tests in Python.")
(home-page "https://testfixtures.readthedocs.io/en/latest/")
(license license:expat)))
+(define-public python-cucumber-tag-expressions
+ (package
+ (name "python-cucumber-tag-expressions")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cucumber-tag-expressions" version))
+ (sha256
+ (base32 "0q7rn4l4ppjd1zsglr37ccc5xccg4iigaw827282zfzfsvzda573"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Ignore the configuration file since we don't
+ ;; need HTML reports, etc.
+ (invoke "pytest" "-c" "/dev/null" "-vv")))))))
+ (native-inputs
+ (list python-invoke python-pathpy python-pytest))
+ (home-page "https://github.com/cucumber/tag-expressions-python")
+ (synopsis "Tag-expression parser for cucumber/behave")
+ (description
+ "This package provides a tag-expression parser for Cucumber and
+@command{behave}.")
+ (license license:expat)))
+
(define-public python-coveralls
(package
(name "python-coveralls")