summaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-01 11:16:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:11 -0500
commitb734ce06e142a6fa29c40919f4cda93d4d8ad700 (patch)
tree63e508e773c8449fd5e4c59a2dd5d4db7cb97d63 /gnu/packages/python-build.scm
parent05e3638bb9275276fe7999f37ff4c5b000337319 (diff)
downloadguix-patches-b734ce06e142a6fa29c40919f4cda93d4d8ad700.tar
guix-patches-b734ce06e142a6fa29c40919f4cda93d4d8ad700.tar.gz
gnu: python-pypa-build: Update to 0.7.0.
* gnu/packages/python-build.scm (python-pypa-build): Update to 0.7.0. [phases]{relax-requirements}: Rename to... {use-toml-instead-of-tomli}: ... this. Replace tomli by toml.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 0688dcbf04..e55044d982 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -250,26 +250,26 @@ information.")
(define-public python-pypa-build
(package
(name "python-pypa-build")
- (version "0.1.0")
+ (version "0.7.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "build" version))
(sha256
(base32
- "1d6m21lijwm04g50nwgsgj7x3vhblzw7jv05ah8psqgzk20bbch8"))))
+ "17xqija27x4my1yrnk6q2vwln60r39g2dhby9zg2l99qjgbdrahs"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ;to tests in the PyPI release
#:phases (modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
+ (add-after 'unpack 'use-toml-instead-of-tomli
+ ;; Using toml instead of tomli eases bootstrapping.
(lambda _
(substitute* "setup.cfg"
- ;; Drop the requirement on python-packaging, which is
- ;; not required.
- ((".*packaging.*")
- "")))))))
+ (("tomli>=.*")
+ "toml\n")))))))
(propagated-inputs
- `(("python-pep517", python-pep517-bootstrap)
+ `(("python-packaging" ,python-packaging-bootstrap)
+ ("python-pep517", python-pep517-bootstrap)
("python-toml" ,python-toml)))
(home-page "https://pypa-build.readthedocs.io/en/latest/")
(synopsis "Simple Python PEP 517 package builder")