summaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-17 12:19:42 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:28 -0500
commit8c95987cbd07b663a29a70ccd9805706a07ac273 (patch)
tree2054ad25228c3227e76d86af69dc1dc365de715c /gnu/packages/python-build.scm
parent59d7550d53f8dd5e31f2bbbd9946ac679eeafc99 (diff)
downloadguix-patches-8c95987cbd07b663a29a70ccd9805706a07ac273.tar
guix-patches-8c95987cbd07b663a29a70ccd9805706a07ac273.tar.gz
gnu: python-pyparsing: Update to 3.0.6.
* gnu/packages/python-build.scm (python-pyparsing): Update to 3.0.6. [properties]: Add a python2-variant property. (python2-pyparsing): Inherit from the 2.4.7 variant, and strip the python2-variant property.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 00fff6b0ea..8bcece74d3 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -199,13 +199,13 @@ Python file, so it can be easily copied into your project.")
(define-public python-pyparsing
(package
(name "python-pyparsing")
- (version "2.4.7")
+ (version "3.0.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyparsing" version))
(sha256
- (base32 "1hgc8qrbq1ymxbwfbjghv01fm3fbpjwpjwi0bcailxxzhf3yq0y2"))))
+ (base32 "109b9r802wb472hgmxclljprh5cid0w3p6mk9alba7pg2c0frgfr"))))
(build-system python-build-system)
(outputs '("out" "doc"))
(arguments
@@ -234,8 +234,10 @@ Python file, so it can be easily copied into your project.")
executing simple grammars, vs. the traditional lex/yacc approach, or the use
of regular expressions. The pyparsing module provides a library of classes
that client code uses to construct the grammar directly in Python code.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-pyparsing))))))
+;;; This is the last release compatible with Python 2.
(define-public python-pyparsing-2.4.7
(package
(inherit python-pyparsing)
@@ -248,7 +250,7 @@ that client code uses to construct the grammar directly in Python code.")
(base32 "1hgc8qrbq1ymxbwfbjghv01fm3fbpjwpjwi0bcailxxzhf3yq0y2"))))))
(define-public python2-pyparsing
- (package-with-python2 python-pyparsing))
+ (package-with-python2 (strip-python2-variant python-pyparsing-2.4.7)))
(define-public python-packaging-bootstrap
(package
@@ -258,9 +260,6 @@ that client code uses to construct the grammar directly in Python code.")
(origin
(method url-fetch)
(uri (pypi-uri "packaging" version))
- ;; XXX: The URL in the patch file is wrong, it should be
- ;; <https://github.com/pypa/packaging/pull/256>.
- (patches (search-patches "python-packaging-test-arch.patch"))
(sha256
(base32
"1sygirdrqgv4f1ckh9nhpcw1yfidrh3qjl86wq8vk6nq4wlw8iyx"))))