summaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 17:52:35 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 17:52:35 -0500
commit4b47c608284bb57a55aa6d1a0b97743405cbad87 (patch)
treeb09673e5d0c952d0ff3cd5172e447ee8429163ed /gnu/packages/python-build.scm
parent05e7bdf7ec1f93efe6cb8a977d7ca08951fc7f6f (diff)
downloadguix-patches-4b47c608284bb57a55aa6d1a0b97743405cbad87.tar
guix-patches-4b47c608284bb57a55aa6d1a0b97743405cbad87.tar.gz
gnu: python-pypa-build: Fix build.
The build was failing following the addition of the sanity-check phase to the Python buidl system. * gnu/packages/python-build.scm (python-pypa-build) [phases]{relax-requirements}: Add phase.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 65b90ddf40..140629ca43 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -127,7 +127,15 @@ Language (TOML) configuration files.")
"1d6m21lijwm04g50nwgsgj7x3vhblzw7jv05ah8psqgzk20bbch8"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f)) ;to tests in the PyPI release
+ `(#:tests? #f ;to tests in the PyPI release
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.cfg"
+ ;; Drop the requirement on python-packaging, which is
+ ;; not required.
+ ((".*packaging.*")
+ "")))))))
(propagated-inputs
`(("python-pep517", python-pep517-bootstrap)
("python-toml" ,python-toml)))