summaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-17 12:14:33 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:28 -0500
commit4b076fb9c2a9c9fe070c00eb3460659ca54cd4cc (patch)
treecfbb22276c2e1905d731fe42aa54ebb523398cd3 /gnu/packages/python-build.scm
parent41cd41a43ce0d0b3d2588e2875192c20e8a3fb5b (diff)
downloadguix-patches-4b076fb9c2a9c9fe070c00eb3460659ca54cd4cc.tar
guix-patches-4b076fb9c2a9c9fe070c00eb3460659ca54cd4cc.tar.gz
gnu: python-packaging-bootstrap: Update to 21.3.
* gnu/packages/python-build.scm (python-packaging-bootstrap): Update to 21.3. (python2-packaging-bootstrap): Peg version to 20.0.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 1db5a6b335..c31e24e08e 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -253,7 +253,7 @@ that client code uses to construct the grammar directly in Python code.")
(define-public python-packaging-bootstrap
(package
(name "python-packaging-bootstrap")
- (version "20.0")
+ (version "21.3")
(source
(origin
(method url-fetch)
@@ -263,7 +263,7 @@ that client code uses to construct the grammar directly in Python code.")
(patches (search-patches "python-packaging-test-arch.patch"))
(sha256
(base32
- "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))
+ "1sygirdrqgv4f1ckh9nhpcw1yfidrh3qjl86wq8vk6nq4wlw8iyx"))))
(build-system python-build-system)
(arguments `(#:tests? #f)) ;disabled to avoid extra dependencies
(propagated-inputs
@@ -280,7 +280,19 @@ information.")
(license (list license:asl2.0 license:bsd-2))))
(define-public python2-packaging-bootstrap
- (package-with-python2 python-packaging-bootstrap))
+ (let ((base (package-with-python2 python-packaging-bootstrap)))
+ (package/inherit base
+ (version "20.0") ;last version with Python 2 support
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "packaging" version))
+ ;; XXX: The URL in the patch file is wrong, it should be
+ ;; <https://github.com/pypa/packaging/pull/256>.
+ (patches (search-patches "python-packaging-test-arch.patch"))
+ (sha256
+ (base32
+ "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy")))))))
;;; The name 'python-pypa-build' is chosen rather than 'python-build' to avoid
;;; a name clash with python-build from (guix build-system python).