summaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-13 11:33:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:18 +0200
commit3bd962bc3c03d859ef8eacf52113d594d83a0815 (patch)
tree7170e2ba382d0efa41b383a59fcb2d1617e6bf17 /gnu/packages/python-build.scm
parent5ce53a4d1c6e88f3ac072ce86ef4746912399298 (diff)
downloadguix-patches-3bd962bc3c03d859ef8eacf52113d594d83a0815.tar
guix-patches-3bd962bc3c03d859ef8eacf52113d594d83a0815.tar.gz
gnu: Add python-pytoml.
* gnu/packages/python-build.scm (python-pytoml): New variable.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 15e671b2c2..13acbca355 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2018, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -89,6 +90,23 @@ installed with a newer @code{pip} or with wheel's own command line utility.")
Language (TOML) configuration files.")
(license license:expat)))
+(define-public python-pytoml
+ (package
+ (name "python-pytoml")
+ (version "0.1.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytoml" version))
+ (sha256
+ (base32
+ "1rv1byiw82k7mj6aprcrqi2vdabs801y97xhfnrz7kxds34ggv4f"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/avakar/pytoml")
+ (synopsis "Parser for TOML")
+ (description "This package provides a Python parser for TOML-0.4.0.")
+ (license license:expat)))
+
(define-public python-pep517-bootstrap
(hidden-package
(package