summaryrefslogtreecommitdiff
path: root/gnu/packages/purescript.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/purescript.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/purescript.scm')
-rw-r--r--gnu/packages/purescript.scm149
1 files changed, 74 insertions, 75 deletions
diff --git a/gnu/packages/purescript.scm b/gnu/packages/purescript.scm
index acb68c4062..fe135be5d9 100644
--- a/gnu/packages/purescript.scm
+++ b/gnu/packages/purescript.scm
@@ -46,69 +46,69 @@
(base32 "06f318hdah076vkviw1ryyg2p0gpbabsp8lbm5x03f2qv92n9j1n"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-glob" ,ghc-glob)
- ("ghc-aeson" ,ghc-aeson)
- ("ghc-aeson-better-errors" ,ghc-aeson-better-errors)
- ("ghc-aeson-pretty" ,ghc-aeson-pretty)
- ("ghc-ansi-terminal" ,ghc-ansi-terminal)
- ("ghc-base-compat" ,ghc-base-compat)
- ("ghc-blaze-html" ,ghc-blaze-html)
- ("ghc-bower-json" ,ghc-bower-json)
- ("ghc-boxes" ,ghc-boxes)
- ("ghc-cborg" ,ghc-cborg)
- ("ghc-cheapskate" ,ghc-cheapskate)
- ("ghc-clock" ,ghc-clock)
- ("ghc-cryptonite" ,ghc-cryptonite)
- ("ghc-data-ordlist" ,ghc-data-ordlist)
- ("ghc-dlist" ,ghc-dlist)
- ("ghc-edit-distance" ,ghc-edit-distance)
- ("ghc-file-embed" ,ghc-file-embed)
- ("ghc-fsnotify" ,ghc-fsnotify)
- ("ghc-happy" ,ghc-happy)
- ("ghc-language-javascript" ,ghc-language-javascript)
- ("ghc-lifted-async" ,ghc-lifted-async)
- ("ghc-lifted-base" ,ghc-lifted-base)
- ("ghc-memory" ,ghc-memory)
- ("ghc-microlens-platform" ,ghc-microlens-platform)
- ("ghc-monad-control" ,ghc-monad-control)
- ("ghc-monad-logger" ,ghc-monad-logger)
- ("ghc-network" ,ghc-network)
- ("ghc-parallel" ,ghc-parallel)
- ("ghc-pattern-arrows" ,ghc-pattern-arrows)
- ("ghc-protolude" ,ghc-protolude)
- ("ghc-purescript-cst" ,ghc-purescript-cst)
- ("ghc-regex-tdfa" ,ghc-regex-tdfa)
- ("ghc-safe" ,ghc-safe)
- ("ghc-scientific" ,ghc-scientific)
- ("ghc-semialign" ,ghc-semialign)
- ("ghc-semigroups" ,ghc-semigroups)
- ("ghc-serialise" ,ghc-serialise)
- ("ghc-sourcemap" ,ghc-sourcemap)
- ("ghc-split" ,ghc-split)
- ("ghc-stringsearch" ,ghc-stringsearch)
- ("ghc-syb" ,ghc-syb)
- ("ghc-these" ,ghc-these)
- ("ghc-transformers-base" ,ghc-transformers-base)
- ("ghc-transformers-compat" ,ghc-transformers-compat)
- ("ghc-unordered-containers" ,ghc-unordered-containers)
- ("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-vector" ,ghc-vector)
- ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
- ("ghc-http-types" ,ghc-http-types)
- ("ghc-network" ,ghc-network)
- ("ghc-optparse-applicative" ,ghc-optparse-applicative-0.15.1.0) ; XXX: needs specific version
- ("ghc-wai" ,ghc-wai)
- ("ghc-wai-websockets" ,ghc-wai-websockets)
- ("ghc-warp" ,ghc-warp)
- ("ghc-websockets" ,ghc-websockets)))
+ (list ghc-glob
+ ghc-aeson
+ ghc-aeson-better-errors
+ ghc-aeson-pretty
+ ghc-ansi-terminal
+ ghc-base-compat
+ ghc-blaze-html
+ ghc-bower-json
+ ghc-boxes
+ ghc-cborg
+ ghc-cheapskate
+ ghc-clock
+ ghc-cryptonite
+ ghc-data-ordlist
+ ghc-dlist
+ ghc-edit-distance
+ ghc-file-embed
+ ghc-fsnotify
+ ghc-happy
+ ghc-language-javascript
+ ghc-lifted-async
+ ghc-lifted-base
+ ghc-memory
+ ghc-microlens-platform
+ ghc-monad-control
+ ghc-monad-logger
+ ghc-network
+ ghc-parallel
+ ghc-pattern-arrows
+ ghc-protolude
+ ghc-purescript-cst
+ ghc-regex-tdfa
+ ghc-safe
+ ghc-scientific
+ ghc-semialign
+ ghc-semigroups
+ ghc-serialise
+ ghc-sourcemap
+ ghc-split
+ ghc-stringsearch
+ ghc-syb
+ ghc-these
+ ghc-transformers-base
+ ghc-transformers-compat
+ ghc-unordered-containers
+ ghc-utf8-string
+ ghc-vector
+ ghc-ansi-wl-pprint
+ ghc-http-types
+ ghc-network
+ ghc-optparse-applicative-0.15.1.0 ; XXX: needs specific version
+ ghc-wai
+ ghc-wai-websockets
+ ghc-warp
+ ghc-websockets))
(native-inputs
- `(("ghc-happy" ,ghc-happy)
- ("ghc-hunit" ,ghc-hunit)
- ("ghc-hspec" ,ghc-hspec)
- ("hspec-discover" ,hspec-discover)
- ("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-golden" ,ghc-tasty-golden)
- ("ghc-tasty-hspec" ,ghc-tasty-hspec)))
+ (list ghc-happy
+ ghc-hunit
+ ghc-hspec
+ hspec-discover
+ ghc-tasty
+ ghc-tasty-golden
+ ghc-tasty-hspec))
(arguments
`(;; Tests require npm
#:tests? #f
@@ -150,16 +150,16 @@ expressive types, inspired by Haskell and compiling to JavaScript.")
(("\\b(dlist)\\s+[^,]+" all dep)
dep)))))))
(inputs
- `(("ghc-aeson" ,ghc-aeson)
- ("ghc-base-compat" ,ghc-base-compat)
- ("ghc-dlist" ,ghc-dlist)
- ("ghc-microlens" ,ghc-microlens)
- ("ghc-protolude" ,ghc-protolude)
- ("ghc-scientific" ,ghc-scientific)
- ("ghc-semigroups" ,ghc-semigroups)
- ("ghc-serialise" ,ghc-serialise)
- ("ghc-vector" ,ghc-vector)))
- (native-inputs `(("ghc-happy" ,ghc-happy)))
+ (list ghc-aeson
+ ghc-base-compat
+ ghc-dlist
+ ghc-microlens
+ ghc-protolude
+ ghc-scientific
+ ghc-semigroups
+ ghc-serialise
+ ghc-vector))
+ (native-inputs (list ghc-happy))
(home-page "https://www.purescript.org/")
(synopsis "PureScript Programming Language Concrete Syntax Tree")
(description
@@ -181,9 +181,8 @@ expressive types, inspired by Haskell and compiling to JavaScript.")
(sha256
(base32 "1ws6y3b3f6hsgv0ff0yp6lw4hba1rps4dnvry3yllng0s5gngcsd"))))
(inputs
- `(("ghc-transformers-compat" ,ghc-transformers-compat)
- ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)))
- (native-inputs `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (list ghc-transformers-compat ghc-ansi-wl-pprint))
+ (native-inputs (list ghc-quickcheck))
(arguments
`(#:cabal-revision
("1" "0zmhqkd96v2z1ilhqdkd9z4jgsnsxb8yi2479ind8m5zm9363zr9")))))