summaryrefslogtreecommitdiff
path: root/gnu/packages/pure.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-03-25 14:11:35 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-03-25 17:02:01 +0200
commit6cf2ac3cd6a42ded34814ac9120c7637cf3f8c7f (patch)
tree948ee8e580a277f5fd090b1d68be0ba2f5623d48 /gnu/packages/pure.scm
parent1679923a2c8ca8f75e1ca69babfaad9e5e5971b6 (diff)
downloadguix-patches-6cf2ac3cd6a42ded34814ac9120c7637cf3f8c7f.tar
guix-patches-6cf2ac3cd6a42ded34814ac9120c7637cf3f8c7f.tar.gz
gnu: Add pure.
* gnu/packages/pure.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/pure.scm')
-rw-r--r--gnu/packages/pure.scm68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnu/packages/pure.scm b/gnu/packages/pure.scm
new file mode 100644
index 0000000000..b0fd93b39b
--- /dev/null
+++ b/gnu/packages/pure.scm
@@ -0,0 +1,68 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages pure)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages llvm)
+ #:use-module (gnu packages multiprecision))
+
+(define-public pure
+ (package
+ (name "pure")
+ (version "0.67")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/agraef/pure-lang/releases/"
+ "download/pure-" version "/"
+ "pure-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hlx5dx6n70rbg668yc97yj4jbnrv0dpfw3l9b0ffmcgr76f6ba4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-llvm-lookup
+ (lambda _
+ (substitute* "configure"
+ (("-lLLVM-[$][{]llvm_version[}]")
+ "`$LLVMCONF --libs`"))
+ #t)))))
+ (inputs
+ `(("gmp" ,gmp)
+ ("llvm" ,llvm-3.5)
+ ("mpfr" ,mpfr)))
+ (home-page "https://agraef.github.io/pure-lang/")
+ (synopsis "Pure programming Language")
+ (description "@code{pure} is a programming language based on term
+rewriting. It offers equational definitions with pattern matching,
+full symbolic rewriting capabilities, dynamic typing, eager and lazy
+evaluation, lexical closures, built-in list and matrix support and
+a C interface.")
+ (license license:gpl3+)))