summaryrefslogtreecommitdiff
path: root/gnu/packages/pumpio.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-02-20 19:53:27 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-02-24 18:00:31 -0500
commit61452a5ab13bcb7ac4d65cfbe7937281204d6f23 (patch)
tree2e6047375e39baf2dd758778845687678db48df3 /gnu/packages/pumpio.scm
parent6e1a7d17f4be26f6ec5bfca49c353218811bc71e (diff)
downloadguix-patches-61452a5ab13bcb7ac4d65cfbe7937281204d6f23.tar
guix-patches-61452a5ab13bcb7ac4d65cfbe7937281204d6f23.tar.gz
gnu: Add pumpa.
* gnu/packages/pumpio.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/pumpio.scm')
-rw-r--r--gnu/packages/pumpio.scm68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnu/packages/pumpio.scm b/gnu/packages/pumpio.scm
new file mode 100644
index 0000000000..4a6375f3f2
--- /dev/null
+++ b/gnu/packages/pumpio.scm
@@ -0,0 +1,68 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages pumpio)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages aspell)
+ #:use-module (gnu packages kde)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages web))
+
+(define-public pumpa
+ (package
+ (name "pumpa")
+ (version "0.9")
+ (source (origin
+ (method git-fetch) ; no source tarballs
+ (uri (git-reference
+ (url "https://gitorious.org/pumpa/pumpa.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0v55xq17wnc9mvpmrm5r3rjrsg9npnjv1lznbz8ppk77ba8pwimy"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-replace
+ 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Fix dependency tests.
+ (substitute* "pumpa.pro"
+ (("/usr/include/tidy\\.h")
+ (string-append (assoc-ref inputs "tidy")
+ "/include/tidy.h"))
+ (("/usr/include/aspell.h")
+ (string-append (assoc-ref inputs "aspell")
+ "/include/aspell.h")))
+ ;; Run qmake with proper installation prefix.
+ (let ((prefix (string-append "PREFIX="
+ (assoc-ref outputs "out"))))
+ (zero? (system* "qmake" prefix))))
+ %standard-phases)))
+ (inputs
+ `(("aspell" ,aspell)
+ ("qt" ,qt)
+ ("qjson" ,qjson)
+ ("tidy" ,tidy)))
+ (synopsis "Qt-based pump.io client")
+ (description "Pumpa is a simple pump.io client written in C++ and Qt.")
+ (home-page "https://pumpa.branchable.com/")
+ (license gpl3+)))