summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-19 18:06:08 -0800
committerLeo Famulari <leo@famulari.name>2018-01-23 15:25:32 -0500
commitc73a00a3763aef0045dd30c252d93ce4d12e76f8 (patch)
tree48db8b210feff9763513d2e581cee8a4de02b2b2 /gnu/packages/pulseaudio.scm
parent8d26f48e8ab3802d73e74b18c877c549c4248eed (diff)
downloadguix-patches-c73a00a3763aef0045dd30c252d93ce4d12e76f8.tar
guix-patches-c73a00a3763aef0045dd30c252d93ce4d12e76f8.tar.gz
gnu: libsndfile: Fix CVE-2017-12562.
* gnu/packages/patches/libsndfile-CVE-2017-12562.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/pulseaudio.scm (libsndfile)[replacement]: New field. (libsndfile/fixed): New variable.
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index ba288aa441..39f54437cb 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -47,6 +47,7 @@
(define-public libsndfile
(package
(name "libsndfile")
+ (replacement libsndfile/fixed)
(version "1.0.28")
(source (origin
(method url-fetch)
@@ -80,6 +81,15 @@ SPARC. Hopefully the design of the library will also make it easy to extend
for reading and writing new sound file formats.")
(license l:gpl2+)))
+(define libsndfile/fixed
+ (package
+ (inherit libsndfile)
+ (source (origin
+ (inherit (package-source libsndfile))
+ (patches (append
+ (origin-patches (package-source libsndfile))
+ (search-patches "libsndfile-CVE-2017-12562.patch")))))))
+
(define-public libsamplerate
(package
(name "libsamplerate") ; aka. Secret Rabbit Code (SRC)