summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-14 19:05:45 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-14 19:05:45 +0100
commit7edafc884c2a21258541b17a231051702c458263 (patch)
treed4202c8d6516bacd32fa55ee23c54b069ef8abd6 /gnu/packages/pulseaudio.scm
parent89da127035737bdf922bc566970c5506c2e01b00 (diff)
parent64fc4f3705423c83c680a95d8dea81a39fce9a70 (diff)
downloadguix-patches-7edafc884c2a21258541b17a231051702c458263.tar
guix-patches-7edafc884c2a21258541b17a231051702c458263.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm77
1 files changed, 77 insertions, 0 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 62d555d788..7c4c26f009 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Amin Bandali <mab@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,9 +40,11 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages dbm)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages web)
@@ -385,3 +388,77 @@ install one or more of the following packages alongside pulseaudio-dlna:
@item vorbis-tools - Vorbis transcoding support
@end itemize")
(license l:gpl3+))))
+
+(define-public pamixer
+ (package
+ (name "pamixer")
+ (version "1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cdemoulins/pamixer.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1i14550n8paijwwnhksv5izgfqm3s5q2773bdfp6vyqybkll55f7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There is no test suite.
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There's no configure phase.
+ (add-before 'install 'mkdir-bin
+ (lambda _
+ (mkdir-p (string-append (assoc-ref %outputs "out") "/bin"))
+ #t)))))
+ (inputs
+ `(("boost" ,boost)
+ ("pulseaudio" ,pulseaudio)))
+ (home-page "https://github.com/cdemoulins/pamixer")
+ (synopsis "PulseAudio command line mixer")
+ (description
+ "pamixer is like amixer but for PulseAudio, allowing easy control of the
+volume levels of the sinks (get, set, decrease, increase, toggle mute, etc).")
+ (license l:gpl3+)))
+
+(define-public pasystray
+ (package
+ (name "pasystray")
+ (version "0.7.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/christophgysin/pasystray.git")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xx1bm9kimgq11a359ikabdndqg5q54pn1d1dyyjnrj0s41168fk"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'bootstrap 'remove-bootstrap.sh
+ (lambda _
+ ;; Interferes with the bootstrap phase.
+ (delete-file "bootstrap.sh")
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("avahi" ,avahi)
+ ("gtk+" ,gtk+)
+ ("libnotify" ,libnotify)
+ ("libx11" ,libx11)
+ ("pulseaudio" ,pulseaudio)))
+ (home-page "https://github.com/christophgysin/pasystray")
+ (synopsis "PulseAudio controller for the system tray")
+ (description "@command{pasystray} enables control of various
+PulseAudio server settings from the X11 system tray. See the project
+README.md for a detailed list of features.")
+ (license l:lgpl2.1+)))