summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-11 22:22:37 +0200
committerMarius Bakke <marius@gnu.org>2020-10-13 23:48:16 +0200
commit171c1f5ab339502e50caf0cdf56e89342aef661e (patch)
treed263be830a0bf5359273c67cb8bc87ad3c390cae /gnu/packages/pulseaudio.scm
parent5e5b664bf7434e0ecbacd6f52c5da38654c76fd9 (diff)
downloadguix-patches-171c1f5ab339502e50caf0cdf56e89342aef661e.tar
guix-patches-171c1f5ab339502e50caf0cdf56e89342aef661e.tar.gz
gnu: libsndfile: Remove graft for 1.0.30.
* gnu/packages/patches/libsndfile-CVE-2017-12562.patch, gnu/packages/patches/libsndfile-CVE-2017-8361-8363-8365.patch, gnu/packages/patches/libsndfile-CVE-2017-8362.patch, gnu/packages/patches/libsndfile-armhf-type-checks.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/pulseaudio.scm (libsndfile): Update to 1.0.30. [replacement]: Remove. [source](uri): Adjust for new URL. [source](patches): Remove. [source](modules, snippet): Incorporate from LIBSNDFILE-1.0.30. [native-inputs]: Add PYTHON. (libsndfile-1.0.30): Remove variable.
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm62
1 files changed, 21 insertions, 41 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index d5c24c264a..d9e9488484 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -71,45 +71,6 @@
(define-public libsndfile
(package
(name "libsndfile")
- (version "1.0.28")
- (replacement libsndfile-1.0.30)
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-"
- version ".tar.gz"))
- (patches (search-patches "libsndfile-armhf-type-checks.patch"
- "libsndfile-CVE-2017-8361-8363-8365.patch"
- "libsndfile-CVE-2017-8362.patch"
- "libsndfile-CVE-2017-12562.patch"))
- (sha256
- (base32
- "1afzm7jx34jhqn32clc5xghyjglccam2728yxlx37yj2y0lkkwqz"))))
- (build-system gnu-build-system)
- (inputs
- `(("libvorbis" ,libvorbis)
- ("libogg" ,libogg)
- ("flac" ,flac)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "http://www.mega-nerd.com/libsndfile/")
- (synopsis "Reading and writing files containing sampled sound")
- (description
- "Libsndfile is a C library for reading and writing files containing
-sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format) through
-one standard library interface.
-
-It was designed to handle both little-endian (such as WAV) and
-big-endian (such as AIFF) data, and to compile and run correctly on
-little-endian (such as Intel and DEC/Compaq Alpha) processor systems as well
-as big-endian processor systems such as Motorola 68k, Power PC, MIPS and
-SPARC. Hopefully the design of the library will also make it easy to extend
-for reading and writing new sound file formats.")
- (license l:gpl2+)))
-
-;; Replacement package to fix multiple security vulnerabilities.
-(define libsndfile-1.0.30
- (package
- (inherit libsndfile)
(version "1.0.30")
(source (origin
(method url-fetch)
@@ -137,9 +98,28 @@ for reading and writing new sound file formats.")
(substitute* "tests/test_wrapper.sh.in"
(("^/usr/bin/env") "env"))
#t))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libvorbis" ,libvorbis)
+ ("libogg" ,libogg)
+ ("flac" ,flac)))
(native-inputs
- `(("python" ,python)
- ,@(package-native-inputs libsndfile)))))
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "http://www.mega-nerd.com/libsndfile/")
+ (synopsis "Reading and writing files containing sampled sound")
+ (description
+ "Libsndfile is a C library for reading and writing files containing
+sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format) through
+one standard library interface.
+
+It was designed to handle both little-endian (such as WAV) and
+big-endian (such as AIFF) data, and to compile and run correctly on
+little-endian (such as Intel and DEC/Compaq Alpha) processor systems as well
+as big-endian processor systems such as Motorola 68k, Power PC, MIPS and
+SPARC. Hopefully the design of the library will also make it easy to extend
+for reading and writing new sound file formats.")
+ (license l:gpl2+)))
(define-public libsamplerate
(package