summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
authorStefan Reichoer <stefan@xsteve.at>2017-04-17 21:35:33 +0200
committerLeo Famulari <leo@famulari.name>2017-04-17 16:37:21 -0400
commit05bdb5e64dea826552510cfeba8c63bcf487dcad (patch)
tree6d8ffeb2e32d2e99523246ef70e58c02ce93c4d4 /gnu/packages/pulseaudio.scm
parent7eaa8cf2b9d1458b90969f2c01b40f3851e07ef6 (diff)
downloadguix-patches-05bdb5e64dea826552510cfeba8c63bcf487dcad.tar
guix-patches-05bdb5e64dea826552510cfeba8c63bcf487dcad.tar.gz
gnu: Add ponymix.
* gnu/packages/pulseaudio.scm (ponymix): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 71fcc3f827..d258c59fa5 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -247,3 +248,38 @@ sound server.")
graphical user interface to connect to a PulseAudio server and
easily control the volume of all clients, sinks, etc.")
(license l:gpl2+)))
+
+(define-public ponymix
+ (package
+ (name "ponymix")
+ (version "5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/falconindy/ponymix/"
+ "archive/" version ".tar.gz"))
+ (sha256
+ (base32
+ "1c0ch98zry3c4ixywwynjid1n1nh4xl4l1p548giq2w3zwflaghn"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There is no test suite.
+ #:make-flags (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "DESTDIR=" out)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr") ""))))
+ (delete 'configure)))) ; There's no configure phase.
+ (inputs
+ `(("pulseaudio" ,pulseaudio)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/falconindy/ponymix")
+ (synopsis "Console-based PulseAudio mixer")
+ (description "Ponymix is a PulseAudio mixer and volume controller with a
+command-line interface. In addition, it is possible to use named sources and
+sinks.")
+ (license l:expat)))