summaryrefslogtreecommitdiff
path: root/gnu/packages/pth.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-09 16:14:23 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-09 16:14:23 +0200
commita22dc0c49aed0babe16ef92ae24847b343b7eb02 (patch)
tree2d1ce88952d68274437dc07fbffbea688bc0eea3 /gnu/packages/pth.scm
parent668d48a6847bcdc69d2c6e6aa44090f566ecd05b (diff)
downloadguix-patches-a22dc0c49aed0babe16ef92ae24847b343b7eb02.tar
guix-patches-a22dc0c49aed0babe16ef92ae24847b343b7eb02.tar.gz
Synchronize package descriptions with the Womb.
* gnu/packages/algebra.scm, gnu/packages/aspell.scm, gnu/packages/autotools.scm, gnu/packages/base.scm, gnu/packages/bash.scm, gnu/packages/bison.scm, gnu/packages/cdrom.scm, gnu/packages/cflow.scm, gnu/packages/compression.scm, gnu/packages/cpio.scm, gnu/packages/cppi.scm, gnu/packages/ddrescue.scm, gnu/packages/dejagnu.scm, gnu/packages/ed.scm, gnu/packages/emacs.scm, gnu/packages/fdisk.scm, gnu/packages/freeipmi.scm, gnu/packages/gawk.scm, gnu/packages/gcal.scm, gnu/packages/gcc.scm, gnu/packages/gdb.scm, gnu/packages/gdbm.scm, gnu/packages/gettext.scm, gnu/packages/ghostscript.scm, gnu/packages/global.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gnutls.scm, gnu/packages/gperf.scm, gnu/packages/gprolog.scm, gnu/packages/groff.scm, gnu/packages/grub.scm, gnu/packages/gsasl.scm, gnu/packages/guile.scm, gnu/packages/gv.scm, gnu/packages/help2man.scm, gnu/packages/idutils.scm, gnu/packages/indent.scm, gnu/packages/less.scm, gnu/packages/libidn.scm, gnu/packages/libsigsegv.scm, gnu/packages/libunistring.scm, gnu/packages/lightning.scm, gnu/packages/linux.scm, gnu/packages/lsh.scm, gnu/packages/m4.scm, gnu/packages/mail.scm, gnu/packages/maths.scm, gnu/packages/multiprecision.scm, gnu/packages/nano.scm, gnu/packages/ncurses.scm, gnu/packages/nettle.scm, gnu/packages/ocrad.scm, gnu/packages/oggvorbis.scm, gnu/packages/parted.scm, gnu/packages/plotutils.scm, gnu/packages/pth.scm, gnu/packages/readline.scm, gnu/packages/recutils.scm, gnu/packages/rush.scm, gnu/packages/scheme.scm, gnu/packages/screen.scm, gnu/packages/shishi.scm, gnu/packages/smalltalk.scm, gnu/packages/system.scm, gnu/packages/texinfo.scm, gnu/packages/time.scm, gnu/packages/unrtf.scm, gnu/packages/version-control.scm, gnu/packages/wdiff.scm, gnu/packages/wget.scm, gnu/packages/which.scm, gnu/packages/xnee.scm, gnu/packages/zile.scm: Change value of the 'description' field to that of the Womb.
Diffstat (limited to 'gnu/packages/pth.scm')
-rw-r--r--gnu/packages/pth.scm26
1 files changed, 7 insertions, 19 deletions
diff --git a/gnu/packages/pth.scm b/gnu/packages/pth.scm
index c3f572574e..e7068a5240 100644
--- a/gnu/packages/pth.scm
+++ b/gnu/packages/pth.scm
@@ -39,23 +39,11 @@
(home-page "http://www.gnu.org/software/pth")
(synopsis "Portable thread library")
(description
- "Pth is a very portable POSIX/ANSI-C based library for Unix
-platforms which provides non-preemptive priority-based scheduling for
-multiple threads of execution (aka ``multithreading'') inside
-event-driven applications. All threads run in the same address space of
-the server application, but each thread has it's own individual
-program-counter, run-time stack, signal mask and errno variable.
-
-The thread scheduling itself is done in a cooperative way, i.e., the
-threads are managed by a priority- and event-based non-preemptive
-scheduler. The intention is that this way one can achieve better
-portability and run-time performance than with preemptive
-scheduling. The event facility allows threads to wait until various
-types of events occur, including pending I/O on file descriptors,
-asynchronous signals, elapsed timers, pending I/O on message ports,
-thread and process termination, and even customized callback functions.
-
-Additionally Pth provides an optional emulation API for POSIX.1c
-threads (\"Pthreads\") which can be used for backward compatibility to
-existing multithreaded applications.")
+ "Pth is a portable library providing non-preemptive, priority-based
+scheduling for multiple execution threads. Each thread has its own
+program-counter, run-time stack, signal mask and errno variable. Threads are
+scheduled in a cooperative way, rather than in the standard preemptive way,
+such that they are managed according to priority and events. However, Pth
+also features emulation of POSIX.1c threads (\"Pthreads\") for backwards
+compatibility.")
(license lgpl2.1+)))