summaryrefslogtreecommitdiff
path: root/gnu/packages/pth.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-02 11:51:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-02 11:51:43 +0200
commit10045e5c81b6dfcf3804ceb1bb4b8df04bde7c98 (patch)
tree6948d9a3b15d4d7f3065aedd85b6681db03f1b2d /gnu/packages/pth.scm
parentcec21d689d1ee0c2dbd2b1c81887a51b2b3279b5 (diff)
downloadguix-patches-10045e5c81b6dfcf3804ceb1bb4b8df04bde7c98.tar
guix-patches-10045e5c81b6dfcf3804ceb1bb4b8df04bde7c98.tar.gz
gnu: pth: Add support for aarch64.
* gnu/packages/pth.scm (pth)[arguments]: When compiling on aarch64 add the '--host=aarch64' flag. [home-page]: Use https.
Diffstat (limited to 'gnu/packages/pth.scm')
-rw-r--r--gnu/packages/pth.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/pth.scm b/gnu/packages/pth.scm
index 50385b14f8..ed6637b330 100644
--- a/gnu/packages/pth.scm
+++ b/gnu/packages/pth.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,8 +38,13 @@
"0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
(build-system gnu-build-system)
(arguments
- '(#:parallel-build? #f))
- (home-page "http://www.gnu.org/software/pth")
+ `(#:parallel-build? #f
+ #:configure-flags (list
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '()))))
+ (home-page "https://www.gnu.org/software/pth")
(synopsis "Portable thread library")
(description
"GNU Pth is a portable library providing non-preemptive, priority-based