summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-10-20 17:45:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-10-20 19:48:33 +0200
commitfa9ac83ec4098ba89c8cc3c9671144fe853fbc06 (patch)
tree89c272f984db95098f60ae1dfa03eed8dfbb3988 /gnu/packages/protobuf.scm
parent77aa706ab6695f24abae88f091aa357546eff5d3 (diff)
downloadguix-patches-fa9ac83ec4098ba89c8cc3c9671144fe853fbc06.tar
guix-patches-fa9ac83ec4098ba89c8cc3c9671144fe853fbc06.tar.gz
gnu: ola: Build with protobuf@2.
This follows up commit dd12d4aad02fc83e00e7b09d676aa78bcb7dd476. * gnu/packages/protobuf.scm (protobuf-2): New variable. * gnu/packages/lighting.scm (ola)[propagated-inputs]: Use it.
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 54955823cc..2e681ca97d 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,19 @@ yet extensible format. Google uses Protocol Buffers for almost all of its
internal RPC protocols and file formats.")
(license bsd-3)))
+;; XXX Remove this old version when no other packages depend on it.
+(define-public protobuf-2
+ (package (inherit protobuf)
+ (version "2.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/google/protobuf/releases/"
+ "download/v" version "/protobuf-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))))
+
(define-public protobuf-c
(package
(name "protobuf-c")