summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-01 11:43:20 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-03 08:54:26 +0200
commitba4d96d22f5c063c9becd7b16410508a6d278dd6 (patch)
tree7440a55d2c20199e76229df9281436b5a8d7f31b /gnu/packages/protobuf.scm
parenteb09a99f81a38edaa4fd43634dcf73f8851832f4 (diff)
downloadguix-patches-ba4d96d22f5c063c9becd7b16410508a6d278dd6.tar
guix-patches-ba4d96d22f5c063c9becd7b16410508a6d278dd6.tar.gz
gnu: python-protobuf: Update to 3.12.4.
* gnu/packages/protobuf.scm (python-protobuf): Update to 3.12.4. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 7c14ddbdfa..b8bd617eca 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -206,15 +207,17 @@ encoder in C++. The developer using protozero has to manually translate the
(define-public python-protobuf
(package
(name "python-protobuf")
- (version "3.11.3")
+ (version "3.12.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "protobuf" version))
(sha256
(base32
- "07qby3yc2a8a1vsxnc79j687q4r68k1d3npni7bldwmd3m6rfz67"))))
+ "0mj6z58aiw532s1mq48m9xdrm3gdyp2vv9cdinfb5wmnfpm5m7n9"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-wheel" ,python-wheel)))
(propagated-inputs
`(("python-six" ,python-six)))
(home-page "https://github.com/google/protobuf")