summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-11 21:38:28 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-11 21:38:28 +0200
commit14d17788a942424fd1825d72b043f1b67e31900b (patch)
tree0fb5c3fdb7197bf0d01ddaf1ade42c794e0c6934 /gnu/packages/protobuf.scm
parent616d9e1d2cc5f2c2dbee86008d040e701692a416 (diff)
downloadguix-patches-14d17788a942424fd1825d72b043f1b67e31900b.tar
guix-patches-14d17788a942424fd1825d72b043f1b67e31900b.tar.gz
gnu: Add Protobuf.
* gnu/packages/protobuf.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
new file mode 100644
index 0000000000..03d1edcee7
--- /dev/null
+++ b/gnu/packages/protobuf.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages protobuf)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses)
+ #:select (bsd-3))
+ #:use-module (gnu packages compression))
+
+(define-public protobuf
+ (package
+ (name "protobuf")
+ (version "2.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://protobuf.googlecode.com/files/protobuf-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0xxn9gxhvsgzz2sgmihzf6pf75clr05mqj6218camwrwajpcbgqk"))))
+ (build-system gnu-build-system)
+ (inputs `(("zlib" ,zlib)))
+ (home-page "http://code.google.com/p/protobuf/")
+ (synopsis "Data encoding for remote procedure calls (RPCs)")
+ (description
+ "Protocol Buffers are a way of encoding structured data in an efficient
+yet extensible format. Google uses Protocol Buffers for almost all of its
+internal RPC protocols and file formats.")
+ (license bsd-3)))