summaryrefslogtreecommitdiff
path: root/gnu/packages/prolog.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-12-13 21:46:26 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-03 19:59:00 -0600
commit3f37f3909712eb7269b6e8184c0d61bfc61b67f9 (patch)
treeebb84174564b9178d0b3f707b0e3ab0326381ecb /gnu/packages/prolog.scm
parentd98e64b4e5b46a67b582df5032647bb169427d6d (diff)
downloadguix-patches-3f37f3909712eb7269b6e8184c0d61bfc61b67f9.tar
guix-patches-3f37f3909712eb7269b6e8184c0d61bfc61b67f9.tar.gz
gnu: Add swi-prolog.
* gnu/packages/prolog.scm (swi-prolog): New variable.
Diffstat (limited to 'gnu/packages/prolog.scm')
-rw-r--r--gnu/packages/prolog.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/prolog.scm b/gnu/packages/prolog.scm
index 7c344988d5..20e6119731 100644
--- a/gnu/packages/prolog.scm
+++ b/gnu/packages/prolog.scm
@@ -67,3 +67,46 @@ manner. It also features an interactive interpreter.")
(supported-systems (fold delete
%supported-systems
'("armhf-linux" "mips64el-linux")))))
+
+;; TODO: This current version of SWI-PROLOG using the
+;; tarball from the official website is completely self-contained
+;; such that all submodules are provided. Eventually replace this
+;; and manually patch those submodules.
+(define-public swi-prolog
+ (package
+ (name "swi-prolog")
+ (version "8.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.swi-prolog.org/download/stable/src/swipl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bnnwbdxnifb1qj42prsqhx8y0k2z596wgvh4bbnd0bw8w59rrff"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:parallel-build? #f
+ #:tests? #t)) ; FIXME:
+ ;#:configure-flags
+ ; (list "-DINSTALL_DOCUMENTATION=OFF"))) ; FIXME:
+ (native-inputs
+ `(("zlib" ,zlib)
+ ("gmp" ,gmp)
+ ("readline" ,readline)
+ ;("texlive" ,texlive)
+ ("texinfo" ,texinfo)
+ ("libunwind" ,libunwind)
+ ("libjpeg", libjpeg)
+ ("libxft" ,libxft)
+ ("fontconfig" ,fontconfig)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("openssl" ,openssl)))
+ (home-page "https://www.swi-prolog.org/")
+ (synopsis "ISO/Edinburgh-style Prolog interpreter")
+ (description "SWI-Prolog is a fast and powerful ISO/Edinburgh-style Prolog
+compiler with a rich set of built-in predicates. It offers a fast, robust and
+small environment which enables substantial applications to be developed with
+it.")
+ (license #f))) ; TODO: