summaryrefslogtreecommitdiff
path: root/gnu/packages/profiling.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-04 17:20:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-04 18:03:46 +0100
commitac1a9ce8b07f3b80900ee08436ff6e683e8dc195 (patch)
treeeb228fc8645a35df24562cc350f21521aabcde0f /gnu/packages/profiling.scm
parent635dd0cc96a5d06933a52a48bb9520efbd567550 (diff)
downloadguix-patches-ac1a9ce8b07f3b80900ee08436ff6e683e8dc195.tar
guix-patches-ac1a9ce8b07f3b80900ee08436ff6e683e8dc195.tar.gz
gnu: papi: Update phase style.
* gnu/packages/profiling.scm (papi)[arguments]: Substitute INVOKE for SYSTEM*, end phases with #t, and don't explicitly install LICENSE.txt.
Diffstat (limited to 'gnu/packages/profiling.scm')
-rw-r--r--gnu/packages/profiling.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/profiling.scm b/gnu/packages/profiling.scm
index 4fdf260c67..35f9d3884f 100644
--- a/gnu/packages/profiling.scm
+++ b/gnu/packages/profiling.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Dave Love <fx@gnu.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -84,7 +85,8 @@ stealtime lmsensors infiniband powercap"
(add-before 'configure 'autoconf
(lambda _
(chdir "src")
- (zero? (system* "autoconf"))))
+ (invoke "autoconf")
+ #t))
;; Amalgamating with the following clause gives double substitution.
(add-before 'patch-source-shebangs 'patch-components
(lambda _
@@ -95,26 +97,24 @@ stealtime lmsensors infiniband powercap"
(add-after 'configure 'components
(lambda* (#:key inputs #:allow-other-keys)
(with-directory-excursion "components"
- (and
- (with-directory-excursion "infiniband_umad"
- (zero? (system* "./configure")))
- (with-directory-excursion "lmsensors"
- (let ((base (assoc-ref inputs "lm-sensors")))
- (zero?
- (system*
- "./configure"
- (string-append "--with-sensors_incdir=" base
- "/include/sensors")
- (string-append "--with-sensors_libdir=" base "/lib")))))))))
+ (with-directory-excursion "infiniband_umad"
+ (invoke "./configure"))
+ (with-directory-excursion "lmsensors"
+ (let ((base (assoc-ref inputs "lm-sensors")))
+ (invoke "./configure"
+ (string-append "--with-sensors_incdir="
+ base "/include/sensors")
+ (string-append "--with-sensors_libdir="
+ base "/lib")))))
+ #t))
(add-after 'install 'extra-doc
(lambda* (#:key outputs #:allow-other-keys)
(let ((doc (string-append (assoc-ref outputs "out")
"/share/doc")))
- (mkdir-p doc)
(chdir "..") ; we went into src above
(for-each (lambda (file)
(install-file file doc))
- '("README" "RELEASENOTES.txt" "LICENSE.txt"))
+ '("README" "RELEASENOTES.txt"))
#t))))))
(home-page "http://icl.cs.utk.edu/papi/")
(synopsis "Performance Application Programming Interface")