summaryrefslogtreecommitdiff
path: root/gnu/packages/profiling.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/profiling.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/profiling.scm')
-rw-r--r--gnu/packages/profiling.scm41
1 files changed, 18 insertions, 23 deletions
diff --git a/gnu/packages/profiling.scm b/gnu/packages/profiling.scm
index b4d52d8d85..3cfe89d963 100644
--- a/gnu/packages/profiling.scm
+++ b/gnu/packages/profiling.scm
@@ -57,14 +57,11 @@
(sha256 (base32 "1m62s8fkjjgq04ayf18jcxc33rqfd7nrkdw1gr54q5pn4cijrp29"))))
(build-system gnu-build-system)
(inputs
- `(("ncurses" ,ncurses)
- ("lm-sensors" ,lm-sensors "lib")
- ("rdma-core" ,rdma-core)
- ("infiniband-diags" ,infiniband-diags "lib")
- ("net-tools" ,net-tools)))
+ (list ncurses
+ `(,lm-sensors "lib") rdma-core
+ `(,infiniband-diags "lib") net-tools))
(native-inputs
- `(("autoconf" ,autoconf)
- ("gfortran" ,gfortran)))
+ (list autoconf gfortran))
(arguments
`(#:tests? #f ; no check target
#:configure-flags
@@ -147,7 +144,7 @@ performance measurement opportunites across the hardware and software stack.")
(uri (string-append "http://www.vi-hps.org/upload/packages/otf2/otf2-"
version ".tar.gz"))
(sha256 (base32 "1ls7rz6qwnqbkifpafc95bnfh3m9xbs74in8zxlnhfbgwx11nn81"))))
- (native-inputs `(("python" ,python)))
+ (native-inputs (list python))
(outputs '("doc" ; 18MB
"lib"
"out"))
@@ -182,9 +179,9 @@ memory-efficient event trace data format plus support library.")
(sha256
(base32 "1xaf25lcxk4ky1kzfks40ja9mayh8pnmrzch2107c8dcjrsxsd4h"))))
(build-system gnu-build-system)
- (inputs `(("gfortran" ,gfortran)))
- (native-inputs `(("gawk" ,gawk) ; for tests
- ("which" ,which)))
+ (inputs (list gfortran))
+ (native-inputs (list gawk ; for tests
+ which))
(home-page "https://www.vi-hps.org/projects/score-p")
(synopsis "OpenMP runtime performance measurement instrumenter")
(description "OPARI2 is a source-to-source instrumentation tool for OpenMP
@@ -204,11 +201,9 @@ with calls to the POMP2 measurement interface.")
version ".tar.gz"))
(sha256 (base32 "04irflia4rfw02093w9nx7rr98r640y4q8hisjywvd4b7r3nzhhx"))
(patches (search-patches "cube-nocheck.patch"))))
- (inputs `(("dbus" ,dbus)
- ("zlib" ,zlib)))
- (native-inputs `(("perl" ,perl)
- ("qtbase" ,qtbase-5) ; native because of qmake
- ("which" ,which)))
+ (inputs (list dbus zlib))
+ (native-inputs (list perl qtbase-5 ; native because of qmake
+ which))
;; FIXME: The doc is 14MB, but adding a doc output results in a cycle.
(outputs '("out" ;"doc"
@@ -354,13 +349,13 @@ different kinds of performance behavior.")
("openmpi" ,openmpi)
("zlib" ,zlib)))
(native-inputs
- `(("gfortran" ,gfortran)
- ("flex" ,flex)
- ("cube" ,cube) ;for cube-config
- ("bison" ,bison)
- ("python" ,python)
- ("doxygen" ,doxygen)
- ("which" ,which)))
+ (list gfortran
+ flex
+ cube ;for cube-config
+ bison
+ python
+ doxygen
+ which))
(arguments
`(#:configure-flags
(list "--enable-shared" "--disable-static"