summaryrefslogtreecommitdiff
path: root/gnu/packages/printers.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-01-02 15:30:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-01-02 15:31:01 +0100
commit7d05575ef5b9841c171d6069ff82c471317d6c30 (patch)
tree6a9fd7a8397e278ea6f36e2542a79b490354709d /gnu/packages/printers.scm
parentd9010a35bfb1479b59d88c17612a4dc5f23ae977 (diff)
downloadguix-patches-7d05575ef5b9841c171d6069ff82c471317d6c30.tar
guix-patches-7d05575ef5b9841c171d6069ff82c471317d6c30.tar.gz
gnu: brlaser: Update to 6-1.9d7ddda.
* gnu/packages/printers.scm (brlaser): Update to 6-1.9d7ddda.
Diffstat (limited to 'gnu/packages/printers.scm')
-rw-r--r--gnu/packages/printers.scm62
1 files changed, 32 insertions, 30 deletions
diff --git a/gnu/packages/printers.scm b/gnu/packages/printers.scm
index bbf98ee653..e03582c47b 100644
--- a/gnu/packages/printers.scm
+++ b/gnu/packages/printers.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,34 +75,36 @@ with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
(license license:gpl3+)))
(define-public brlaser
- (package
- (name "brlaser")
- (version "6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pdewacht/brlaser")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1995s69ksq1fz0vb34v0ndiqncrinbrlpmp70rkl6az7kag99s80"))))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags
- (list (string-append "-DCUPS_DATA_DIR="
- (assoc-ref %outputs "out")
- "/share/cups")
- (string-append "-DCUPS_SERVER_BIN="
- (assoc-ref %outputs "out")
- "/lib/cups"))))
- (inputs
- `(("ghostscript" ,ghostscript)
- ("cups" ,cups)
- ("zlib" ,zlib)))
- (home-page "https://github.com/pdewacht/brlaser")
- (synopsis "Brother laser printer driver")
- (description "Brlaser is a CUPS driver for Brother laser printers. This
+ (let ((commit "9d7ddda8383bfc4d205b5e1b49de2b8bcd9137f1")
+ (revision "1"))
+ (package
+ (name "brlaser")
+ (version (git-version "6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pdewacht/brlaser")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1drh0nk7amn9a8wykki4l9maqa4vy7vwminypfy1712alwj31nd4"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCUPS_DATA_DIR="
+ (assoc-ref %outputs "out")
+ "/share/cups")
+ (string-append "-DCUPS_SERVER_BIN="
+ (assoc-ref %outputs "out")
+ "/lib/cups"))))
+ (inputs
+ `(("ghostscript" ,ghostscript)
+ ("cups" ,cups)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/pdewacht/brlaser")
+ (synopsis "Brother laser printer driver")
+ (description "Brlaser is a CUPS driver for Brother laser printers. This
driver is known to work with these printers:
@enumerate
@@ -137,4 +139,4 @@ driver is known to work with these printers:
@item Brother MFC-L2710DW series
@item Lenovo M7605D
@end enumerate")
- (license license:gpl2+)))
+ (license license:gpl2+))))