summaryrefslogtreecommitdiff
path: root/gnu/packages/printers.scm
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2019-11-19 10:44:15 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-20 00:16:51 +0100
commit711e8bf75fdacc8218b3957bbd7cb367da6392b5 (patch)
tree87a72ae2f5053f39201ea9903b25fcf98b5a4c0a /gnu/packages/printers.scm
parentaf6a9fc27622ea8a342fe18c8604f2fe64a04e68 (diff)
downloadguix-patches-711e8bf75fdacc8218b3957bbd7cb367da6392b5.tar
guix-patches-711e8bf75fdacc8218b3957bbd7cb367da6392b5.tar.gz
gnu: brlaser: Update to 6.
* gnu/packages/printers.scm (brlaser): Update to 6. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/printers.scm')
-rw-r--r--gnu/packages/printers.scm84
1 files changed, 49 insertions, 35 deletions
diff --git a/gnu/packages/printers.scm b/gnu/packages/printers.scm
index 2d608bf3cb..7b2c2429dd 100644
--- a/gnu/packages/printers.scm
+++ b/gnu/packages/printers.scm
@@ -75,52 +75,66 @@ with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
(license license:gpl3+)))
(define-public brlaser
- (let ((commit "779f71e80fcc583f4537c844de141cf8e6a738fe")
- (revision "1"))
- (package
- (name "brlaser")
- (version (git-version "4" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pdewacht/brlaser.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0yrz9706660hdfi2y0ndp254r0vw9y665hwmxbbzfnz4ai13vj50"))))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags
- (list (string-append "-DCUPS_DATA_DIR="
- (assoc-ref %outputs "out")
- "/share/cups")
- (string-append "-DCUPS_SERVER_BIN="
- (assoc-ref %outputs "out")
- "/lib/cups"))))
- (inputs
- `(("ghostscript" ,ghostscript)
- ("cups" ,cups)
- ("zlib" ,zlib)))
- (home-page "https://github.com/pdewacht/brlaser")
- (synopsis "Brother laser printer driver")
- (description "Brlaser is a CUPS driver for Brother laser printers. This
+ (package
+ (name "brlaser")
+ (version "6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pdewacht/brlaser.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1995s69ksq1fz0vb34v0ndiqncrinbrlpmp70rkl6az7kag99s80"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCUPS_DATA_DIR="
+ (assoc-ref %outputs "out")
+ "/share/cups")
+ (string-append "-DCUPS_SERVER_BIN="
+ (assoc-ref %outputs "out")
+ "/lib/cups"))))
+ (inputs
+ `(("ghostscript" ,ghostscript)
+ ("cups" ,cups)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/pdewacht/brlaser")
+ (synopsis "Brother laser printer driver")
+ (description "Brlaser is a CUPS driver for Brother laser printers. This
driver is known to work with these printers:
@enumerate
-@item Brother DCP-1510
+@item Brother DCP-1510 series
+@item Brother DCP-1600 series
@item Brother DCP-7030
@item Brother DCP-7040
@item Brother DCP-7055
@item Brother DCP-7055W
+@item Brother DCP-7060D
@item Brother DCP-7065DN
@item Brother DCP-7080
+@item Brother DCP-L2500D series
+@item Brother DCP-L2520D series
+@item Brother DCP-L2540DW series
+@item Brother HL-1110 series
@item Brother HL-1200 series
+@item Brother HL-2030 series
+@item Brother HL-2140 series
+@item Brother HL-2220 series
+@item Brother HL-2270DW series
+@item Brother HL-5030 series
+@item Brother HL-L2300D series
@item Brother HL-L2320D series
+@item Brother HL-L2340D series
@item Brother HL-L2360D series
+@item Brother MFC-1910W
@item Brother MFC-7240
@item Brother MFC-7360N
-@end enumerate
-
-It partially works with printers from the Brother HL-L2300D series.")
- (license license:gpl2+))))
+@item Brother MFC-7365DN
+@item Brother MFC-7840W
+@item Brother MFC-L2710DW series
+@item Lenovo M7605D
+@end enumerate")
+ (license license:gpl2+)))