summaryrefslogtreecommitdiff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 01:41:40 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 15:52:56 +0100
commit6e48fbb19a420ea0be1d922ebdce36d7beb0240f (patch)
tree069a281f2708a926983440e96654079dd0332783 /gnu/packages/pretty-print.scm
parent3a5c02777d6a51620d8cb8afa01602bc669bbfea (diff)
downloadguix-patches-6e48fbb19a420ea0be1d922ebdce36d7beb0240f.tar
guix-patches-6e48fbb19a420ea0be1d922ebdce36d7beb0240f.tar.gz
gnu: highlight: Don't hard-code Lua version.
* gnu/packages/pretty-print.scm (highlight)[arguments]: Construct the Lua prefix programatically instead of hard-coding it.
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index e8baefa1d4..6edfba95cc 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -27,6 +27,7 @@
#:use-module (guix download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages groff)
@@ -266,7 +267,8 @@ seen in a terminal.")
(lambda _
(substitute* "src/makefile"
(("(pkg-config.*)lua" _ prefix)
- (string-append prefix "lua-5.3")))
+ (string-append prefix "lua-" ,(version-major+minor
+ (package-version lua)))))
#t)))))
(inputs
`(("lua" ,lua)