summaryrefslogtreecommitdiff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-12-03 16:42:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-03 23:26:16 +0100
commit57b94e9d8df4f2f1ea2202751a8e2247099a4d47 (patch)
tree6c49eb1302e602eae5af48d08a73a91531ce2d6d /gnu/packages/pretty-print.scm
parent3bec8a016ff61e3e5dd1af86ee8423af4c168720 (diff)
downloadguix-patches-57b94e9d8df4f2f1ea2202751a8e2247099a4d47.tar
guix-patches-57b94e9d8df4f2f1ea2202751a8e2247099a4d47.tar.gz
gnu: Add highlight.
* gnu/packages/pretty-print.scm (highlight): New variable.
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm46
1 files changed, 45 insertions, 1 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 8ba9780685..8819b8adaf 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,7 +32,9 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages gperf)
- #:use-module (gnu packages perl))
+ #:use-module (gnu packages lua)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config))
(define-public a2ps
(package
@@ -197,6 +200,47 @@ seen in a terminal.")
(license gpl3+)
(properties '((ftp-directory . "/gnu/src-highlite")))))
+(define-public highlight
+ (package
+ (name "highlight")
+ (version "3.33")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.andre-simon.de/zip/highlight-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0g2whi6pxl640795vymikm82a1my841jmh7fiqzbrjpc9wsk1db4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (let ((confdir (string-append %output "/share/highlight/config/")))
+ (list (string-append "PREFIX=" %output)
+ (string-append "HL_CONFIG_DIR=" confdir)
+ (string-append "conf_dir=" confdir)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-search-for-lua
+ (lambda _
+ (substitute* "src/makefile"
+ (("(pkg-config.*)lua" _ prefix)
+ (string-append prefix "lua-5.3")))
+ #t)))))
+ (inputs
+ `(("lua" ,lua)
+ ("boost" ,boost)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.andre-simon.de/doku/highlight/en/highlight.php")
+ (synopsis "Convert code to documents with syntax highlighting")
+ (description "Highlight converts source code to HTML, XHTML, RTF, LaTeX,
+TeX, SVG, BBCode and terminal escape sequences with colored syntax
+highlighting. Language definitions and color themes are customizable.")
+ (license gpl3+)))
+
(define-public astyle
(package
(name "astyle")