summaryrefslogtreecommitdiff
path: root/gnu/packages/polkit.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-01 17:38:44 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-01 17:38:44 +0200
commitcb151c68bfdb207d6029402c4a1c004ebd630d68 (patch)
tree67175d1ac7cb1f9a8d1149ced3e75fd9fd6b8c33 /gnu/packages/polkit.scm
parent78bed82d193d73488f18d76165aa3f809122311f (diff)
downloadguix-patches-cb151c68bfdb207d6029402c4a1c004ebd630d68.tar
guix-patches-cb151c68bfdb207d6029402c4a1c004ebd630d68.tar.gz
gnu: polkit-qt: Add $libdir to RUNPATH.
* gnu/packages/polkit.scm (polkit-qt)[arguments]: Add #:configure-flags.
Diffstat (limited to 'gnu/packages/polkit.scm')
-rw-r--r--gnu/packages/polkit.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 572d52404b..be7302ed49 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -86,7 +86,12 @@ for unprivileged applications.")
(native-inputs
`(("pkg-config", pkg-config)))
(arguments
- `(#:tests? #f)) ; there is a test subdirectory, but no test target
+ `(#:configure-flags (list (string-append "-DCMAKE_INSTALL_RPATH="
+ (assoc-ref %outputs "out")
+ "/lib:"
+ (assoc-ref %outputs "out")
+ "/lib64"))
+ #:tests? #f)) ; there is a test subdirectory, but no test target
(home-page "http://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/")
(synopsis "Qt frontend to the polkit library")
(description "Polkit-qt is a library that lets developers use the