summaryrefslogtreecommitdiff
path: root/gnu/packages/polkit.scm
diff options
context:
space:
mode:
authorHuang Ying <huang.ying.caritas@gmail.com>2017-01-30 11:07:31 +0800
committerLudovic Courtès <ludo@gnu.org>2017-02-01 23:53:35 +0100
commit728dc8fa296e632b86cf56b5d3a52f7bcd6ca4e8 (patch)
tree3f689efca611ab5559b62ec993af975294288ad9 /gnu/packages/polkit.scm
parent7596ddf3f15a90b26f118fd93c3c80cabbb6af6c (diff)
downloadguix-patches-728dc8fa296e632b86cf56b5d3a52f7bcd6ca4e8.tar
guix-patches-728dc8fa296e632b86cf56b5d3a52f7bcd6ca4e8.tar.gz
gnu: Add polkit-gnome.
* gnu/packages/polkit.scm (polkit-gnome): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/polkit.scm')
-rw-r--r--gnu/packages/polkit.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index e224ca22f3..0e38dd61ee 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Huang Ying <huang.ying.caritas@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
@@ -159,3 +161,27 @@ PolicyKit API through a Qt-styled API. It is mainly a wrapper around
QAction and QAbstractButton that lets you integrate those two component
easily with PolicyKit.")
(license lgpl2.0+)))
+
+(define-public polkit-gnome
+ (package
+ (name "polkit-gnome")
+ (version "0.105")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/"
+ name "/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0sckmcbxyj6sbrnfc5p5lnw27ccghsid6v6wxq09mgxqcd4lk10p"))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk+" ,gtk+)
+ ("polkit" ,polkit)))
+ (native-inputs `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Legacy polkit authentication agent for GNOME")
+ (description "PolicyKit-gnome provides a D-Bus session bus service
+that is used to bring up authentication dialogs used for obtaining
+privileges.")
+ (home-page "http://www.freedesktop.org/wiki/Software/polkit/")
+ (license lgpl2.0+)))