summaryrefslogtreecommitdiff
path: root/gnu/packages/polkit.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-24 13:33:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-26 20:13:09 +0100
commit3c4bbb4c52418c8daf8b0e4605e3912685c9f44a (patch)
treebfdfbab8f51c0537df6529b106b8dbcb3e2972ec /gnu/packages/polkit.scm
parent73a3e98f01973b1f92fe9a1b905c6d14c4d8f5ae (diff)
downloadguix-patches-3c4bbb4c52418c8daf8b0e4605e3912685c9f44a.tar
guix-patches-3c4bbb4c52418c8daf8b0e4605e3912685c9f44a.tar.gz
gnu: polkit: Update phase & snippet style.
* gnu/packages/polkit.scm (polkit)[source]: End snippet with #t. [arguments]: Substitute INVOKE for SYSTEM* and end phases with #t.
Diffstat (limited to 'gnu/packages/polkit.scm')
-rw-r--r--gnu/packages/polkit.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 0e38dd61ee..8fe37097e1 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Huang Ying <huang.ying.caritas@gmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -77,7 +78,8 @@
;; Set the setuid helper's real location.
(substitute* "src/polkitagent/polkitagentsession.c"
(("PACKAGE_PREFIX \"/lib/polkit-1/polkit-agent-helper-1\"")
- "\"/run/setuid-programs/polkit-agent-helper-1\""))))))
+ "\"/run/setuid-programs/polkit-agent-helper-1\""))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("expat" ,expat)
@@ -105,7 +107,8 @@
(("@INTROSPECTION_GIRDIR@")
(string-append out "/share/gir-1.0/"))
(("@INTROSPECTION_TYPELIBDIR@")
- (string-append out "/lib/girepository-1.0/"))))))
+ (string-append out "/lib/girepository-1.0/")))
+ #t)))
(replace
'install
(lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
@@ -113,12 +116,12 @@
;; to install in /etc, and to instead install the skeletons in the
;; output directory.
(let ((out (assoc-ref outputs "out")))
- (zero? (apply system*
- "make" "install"
+ (invoke "make" "install"
(string-append "sysconfdir=" out "/etc")
(string-append "polkit_actiondir="
out "/share/polkit-1/actions")
- make-flags))))))))
+ make-flags)
+ #t))))))
(home-page "http://www.freedesktop.org/wiki/Software/polkit/")
(synopsis "Authorization API for privilege management")
(description "Polkit is an application-level toolkit for defining and