summaryrefslogtreecommitdiff
path: root/gnu/packages/polkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-04 18:25:58 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-05 00:37:39 +0200
commit3588419553176daadcb59644037d169574542b42 (patch)
tree047df9dda8330eb966d14515751d51e29f9fad6f /gnu/packages/polkit.scm
parent261e9db2cd9669f74ee47f75907725c7d3d01d1b (diff)
downloadguix-patches-3588419553176daadcb59644037d169574542b42.tar
guix-patches-3588419553176daadcb59644037d169574542b42.tar.gz
gnu: polkit: Update to 0.116 [fixes CVE-2019-6133].
* gnu/packages/patches/polkit-CVE-2018-19788.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/polkit.scm (polkit): Update to 0.116. [source](patches): Remove. [inputs]: Change MOZJS-52 to MOZJS-60. [arguments]: Add CXXFLAGS=-std=gnu++11 to #:configure-flags.
Diffstat (limited to 'gnu/packages/polkit.scm')
-rw-r--r--gnu/packages/polkit.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index ccb8ebf8f8..ac24adef43 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -43,16 +43,15 @@
(define-public polkit
(package
(name "polkit")
- (version "0.115")
+ (version "0.116")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.freedesktop.org/software/polkit/releases/"
name "-" version ".tar.gz"))
- (patches (search-patches "polkit-CVE-2018-19788.patch"))
(sha256
(base32
- "0c91y61y4gy6p91cwbzg32dhavw4b7fflg370rimqhdxpzdfr1rg"))
+ "1c9lbpndh5zis22f154vjrhnqw65z8s85nrgl42v738yf6g0q5w8"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -90,7 +89,7 @@
`(("expat" ,expat)
("linux-pam" ,linux-pam)
("elogind" ,elogind)
- ("mozjs" ,mozjs-52)
+ ("mozjs" ,mozjs-60)
("nspr" ,nspr)))
(propagated-inputs
`(("glib" ,glib))) ; required by polkit-gobject-1.pc
@@ -101,6 +100,9 @@
("gobject-introspection" ,gobject-introspection)))
(arguments
`(#:configure-flags '("--sysconfdir=/etc"
+ ;; XXX: MozJS 60 requires the C++11 ABI or higher.
+ ;; Remove when the default compiler is >= GCC 6.
+ "CXXFLAGS=-std=gnu++11"
"--enable-man-pages")
#:phases
(modify-phases %standard-phases