summaryrefslogtreecommitdiff
path: root/gnu/packages/plotutils.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-15 15:04:45 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-15 23:10:05 +0100
commitceae3fef44f96ccab6f36135cf9e74a341ec84ff (patch)
treee10dc0a78d78aacf326c87f647d5b011d2b3b6aa /gnu/packages/plotutils.scm
parent52958f0dfd098249357cc0b66974bde5e45193e5 (diff)
downloadguix-patches-ceae3fef44f96ccab6f36135cf9e74a341ec84ff.tar
guix-patches-ceae3fef44f96ccab6f36135cf9e74a341ec84ff.tar.gz
gnu: plotutils: Do not propagate libXaw.
* gnu/packages/plotutils.scm (plotutils): Move LIBXAW from 'propagated-inputs' to 'inputs'. Add 'snippet'.
Diffstat (limited to 'gnu/packages/plotutils.scm')
-rw-r--r--gnu/packages/plotutils.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index eae8abaad2..41df88088e 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,14 +36,21 @@
(sha256
(base32
"1arkyizn5wbgvbh53aziv3s6lmd3wm9lqzkhxb3hijlp1y124hjg"))
- (patches (list (search-patch "plotutils-libpng-jmpbuf.patch")))))
+ (patches (list (search-patch "plotutils-libpng-jmpbuf.patch")))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Force the use of libXaw7 instead of libXaw. When not doing
+ ;; that, libplot.la ends up containing just "-lXaw" (without
+ ;; "-L/path/to/Xaw"), due to the fact that there is no
+ ;; libXaw.la, which forces us to propagate libXaw.
+ '(substitute* "configure"
+ (("-lXaw")
+ "-lXaw7")))))
(build-system gnu-build-system)
(inputs `(("libpng" ,libpng)
("libx11" ,libx11)
- ("libxt" ,libxt)))
-
- ;; libplot.la has '-lXaw'.
- (propagated-inputs `(("libxaw" ,libxaw)))
+ ("libxt" ,libxt)
+ ("libxaw" ,libxaw)))
(home-page
"http://www.gnu.org/software/plotutils/")