summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-02-09 17:09:49 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-02-09 17:09:49 +0100
commitf2130228ed86fed81806a662ed59aa74ed2398ed (patch)
treea9def571bd746607eff513dcf48d1fb02b151632 /gnu/packages/php.scm
parent63cc2737d68a626d3b20413c1be95a8eca71f1df (diff)
downloadguix-patches-f2130228ed86fed81806a662ed59aa74ed2398ed.tar
guix-patches-f2130228ed86fed81806a662ed59aa74ed2398ed.tar.gz
gnu: php: Disable failing tests on arm.
* gnu/packages/php.scm (arguments)[phases]: Disable additional failing tests on arm.
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 93428af450..1c71c1f40f 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -183,12 +183,18 @@
"ext/calendar/tests/unixtojd_error1.phpt"
;; arm can be a lot slower, so a time-related test fails
"ext/fileinfo/tests/cve-2014-3538-nojit.phpt"
+ "ext/pcntl/tests/pcntl_unshare_01.phpt"
"ext/pcre/tests/bug76514.phpt"
"ext/pcre/tests/preg_match_error3.phpt"
+ "ext/pcre/tests/cache_limit.phpt"
+ "ext/sockets/tests/socket_getopt.phpt"
+ "ext/sockets/tests/socket_sendrecvmsg_error.phpt"
"ext/standard/tests/general_functions/var_export-locale.phpt"
"ext/standard/tests/general_functions/var_export_basic1.phpt"
"ext/intl/tests/timezone_getErrorCodeMessage_basic.phpt"
- "ext/intl/tests/timezone_getOffset_error.phpt")))
+ "ext/intl/tests/timezone_getOffset_error.phpt"
+ "sapi/cli/tests/cli_process_title_unix.phpt"
+ "sapi/cli/tests/upload_2G.phpt")))
'())
;; Drop tests that are known to fail.