summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-03-28 22:55:17 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-03-28 22:59:14 +0100
commite8cfce439afed945e352ad28f73f0a5f7840f503 (patch)
treeb6b8f98da3039306a6015b36940c802111440a7f /gnu/packages/php.scm
parent241885347a1471212d86d3b181498a0e292ca16a (diff)
downloadguix-patches-e8cfce439afed945e352ad28f73f0a5f7840f503.tar
guix-patches-e8cfce439afed945e352ad28f73f0a5f7840f503.tar.gz
gnu: php: Disable failing tests on armhf.
* gnu/packages/php.scm (php)[arguments]: Disable failing tests on armhf.
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 8d96e54c90..ffb81da5fc 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -86,7 +86,7 @@
#t))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
+ `(#:configure-flags
(let-syntax ((with (syntax-rules ()
((_ option input)
(string-append option "="
@@ -182,6 +182,17 @@
(substitute* "ext/standard/tests/streams/bug60602.phpt"
(("'ls'") (string-append "'" (which "ls") "'")))
+ ,@(if (string-prefix? "armhf" (or (%current-system)
+ (%current-target-system)))
+ ;; Drop tests known to fail on armhf.
+ '((for-each delete-file
+ (list
+ "ext/calendar/tests/unixtojd_error1.phpt"
+ ;; arm can be a lot slower, so a time-related test fails
+ "ext/fileinfo/tests/cve-2014-3538-nojit.phpt"
+ "ext/pcre/tests/bug76514.phpt"
+ "ext/pcre/tests/preg_match_error3.phpt"))))
+
;; Drop tests that are known to fail.
(for-each delete-file
'("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.