summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-29 15:34:37 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-29 15:35:54 +0100
commit9398152ad1f4e130ad895c8bb756de8a33e91f7f (patch)
treebdca2e0dc5db6a40decd75677a3a91af87d4424d /gnu/packages/php.scm
parent46fc7cafcf7dcaaa252591df387541d43df05bb9 (diff)
downloadguix-patches-9398152ad1f4e130ad895c8bb756de8a33e91f7f.tar
guix-patches-9398152ad1f4e130ad895c8bb756de8a33e91f7f.tar.gz
gnu: php: Fix typo.
Regression introduced in e8cfce439afed945e352ad28f73f0a5f7840f503. * gnu/packages/php.scm (php)[arguments]: Add missing 'else' branch of the 'if'. Change first argument to 'string-prefix?' to match GNU triplets as well.
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index ffb81da5fc..ea002f8c59 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -182,8 +182,8 @@
(substitute* "ext/standard/tests/streams/bug60602.phpt"
(("'ls'") (string-append "'" (which "ls") "'")))
- ,@(if (string-prefix? "armhf" (or (%current-system)
- (%current-target-system)))
+ ,@(if (string-prefix? "arm" (or (%current-system)
+ (%current-target-system)))
;; Drop tests known to fail on armhf.
'((for-each delete-file
(list
@@ -191,7 +191,8 @@
;; arm can be a lot slower, so a time-related test fails
"ext/fileinfo/tests/cve-2014-3538-nojit.phpt"
"ext/pcre/tests/bug76514.phpt"
- "ext/pcre/tests/preg_match_error3.phpt"))))
+ "ext/pcre/tests/preg_match_error3.phpt")))
+ '())
;; Drop tests that are known to fail.
(for-each delete-file