summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-01-01 16:53:25 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-01-01 18:57:56 +0300
commit8b6c91ba538f87d519ffa1d5d3fc3324fdaac85f (patch)
tree9418968b6e868f26c06a94152c97122abe8fabca /gnu/packages/php.scm
parent4db80f8b118c28b7adfe7bd6fca7ebadff701bb9 (diff)
downloadguix-patches-8b6c91ba538f87d519ffa1d5d3fc3324fdaac85f.tar
guix-patches-8b6c91ba538f87d519ffa1d5d3fc3324fdaac85f.tar.gz
gnu: php-with-bcmath: Deprecate in favour of 'php'.
This is a follow-up to 4629d26755aa06344fb8f515fb0202776e70c429. * gnu/packages/php.scm (php-with-bcmath): Deprecate in favour of 'php'. * gnu/tests/monitoring.scm (%zabbix-os): Use this.
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 1d33b17a10..a96f1c2259 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -353,10 +354,4 @@ systems, web content management systems and web frameworks." )
license:expat)))) ; ext/date/lib
(define-public php-with-bcmath
- (package
- (inherit php)
- (name "php-with-bcmath")
- (arguments
- (substitute-keyword-arguments (package-arguments php)
- ((#:configure-flags flags)
- `(cons "--enable-bcmath" ,flags))))))
+ (deprecated-package "php-with-bcmath" php))