summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-16 18:44:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-16 19:06:50 +0100
commit88b4dcdabe512992ae79a50fc333e4e463d91634 (patch)
tree08f40e3c3304023e6cf08ab7b8c8cdfc533ea712 /gnu/packages/php.scm
parent13f13554433c9dd47503131107dfbdd8a8031832 (diff)
downloadguix-patches-88b4dcdabe512992ae79a50fc333e4e463d91634.tar
guix-patches-88b4dcdabe512992ae79a50fc333e4e463d91634.tar.gz
gnu: php: Properly fix openssl_x509_checkpurpose_basic.phpt.
* gnu/packages/php.scm (php)[source]: Add patch. * gnu/packages/patches/php-openssl_x509_checkpurpose_basic.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Thanks to Diego Nicola Barbato <dnbarbato@posteo.de>
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index a633e0790b..191dcafb4a 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -70,7 +70,9 @@
(sha256
(base32
"1y0f1xgfi8cks6npdhrycg8r9g3q0pikqgf5h4xafpy8znmb61g3"))
- (patches (search-patches "php-bug-74093-test.patch"))
+ (patches
+ (search-patches "php-bug-74093-test.patch"
+ "php-openssl_x509_checkpurpose_basic.patch"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -343,10 +345,7 @@
;; Renicing a process fails in the build environment.
"ext/standard/tests/general_functions/proc_nice_basic.phpt"
;; Can fail on fast machines?
- "Zend/tests/bug74093.phpt"
-
- ;; Unknown reason <https://issues.guix.gnu.org/52513>.
- "ext/openssl/tests/openssl_x509_checkpurpose_basic.phpt"))
+ "Zend/tests/bug74093.phpt"))
;; Accomodate two extra openssl errors flanking the expected one:
;; random number generator:RAND_{load,write}_file:Cannot open file